Monteray upgrade: has anyone had problems booting Intel Mac from external SSD?

Hi. As per this thread my 2015 iMac that boots from an external SSD has been close to unusable since upgrading to Monteray. Booting takes up to 25 minutes and then the system can be very unresponsive.

A look on the internet shows lots of people seemingly having this problem and associating it with Intel Macs booting off external drives.

To help my diagnosis and sanity, can I ask whether anyone else is experiencing this, and just as importantly, is anyone with an Intel iMac booting from an external drive able to boot into Monteray without any problems?

Thanks

p.s. It’s a SanDisk Extreme SSD

2015 iMac booting off a Samsung T5 and has been fine after my upgrade to Monterey.
CleanShot 2021-11-21 at 18.06.50@2x

1 Like

Thanks. That’s helpful

Booting 2019 5k iMad 27" into Monterey from OWC Envoy Express via thunderbolt with no issues.

I stopped using the SanDisk Extreme as a boot drive because it wouldn’t mount or show up after a restart without unplugging and replugging. Worked fine from a cold boot after shutdown. That was in Big Sur, and I’ve not attempted it in Monterey. My T7 always slowed to a crawl after a few weeks until zeroing out and reformatting.

1 Like

On further testing, I can boot it normally from a clone of my MacBook on a T5 (which wasn’t always perfect with Big Sur). But you have problems with a T7. And I have problems with Sandisk Extreme on Monterey but not Big Sur.

This all seems a bit haphazard in terms of what will work and what won’t!

Is that level of risk just to be accepted when booting from an external drive?

I have been battling this issue over the last couple of weeks. I boot from an external Samsung T5, the system keeps freezing, then restarts, it got to the stage that when I was rebooting I was getting the circle with a line through it suggesting it could not read from the drive.

I tried reinstalling the OS a couple of times through Recovery, it fixed it for a few days and then went back to having the issue.

Yesterday I took out a brand new Samsung T5 and did a fresh install of the OS and then migrated all my settings/files across to this, at the moment it is working fine, i have not had any freezes or instability. I will keep you updated

1 Like

Yes, please do keep us updated. Is this essentially a ‘firmware keeping up with MacOS’ issue do you think?

It is odd, my T5 has been solid starting with Catalina then Big Sur and now Monterey.

1 Like