Monterey Passwords Annoyance

In my attempt to transition to the new Passwords feature in macOS 12.0.1 I have discovered two major annoyances so far. Otherwise I actually like the new feature and see myself making the transition permanent once everything is set. But these two annoyances are making that difficult.

  1. The import passwords feature is extremely sensitive. Without major modifications to the csv file it will not import any records. This is terribly annoying.

  2. The name of the record in Passwords cannot be modified. It is auto-populated based on the domain. This causes confusion when you have multiple passwords on a single domain. I have a few of these and it has already caused problems, particularly when two-factor authentication is active. So, for instance, at a glance, I can’t tell the difference between my Amazon login and my AWS login.

I have yet to find a reasonable solution to either of these problems. Neither a dealbreakers because there are workarounds (albeit tedious) but I hope that these two things are addressed in future updates. They are simple problems to solve, in my estimation. The solution to the first problem would be to just import what is importable and allow the user to modify the record in the Passwords interface as needed. Apple could even prompt the user to do this before they delete their previous records. This would be more efficient than modifying the csv file. The solution to the second is just to allow the user to modify the name of the record. Boom! Solved.

1 Like

I didn’t try the Passwords feature yet, but your point #2 is a dealbreaker for me. I have a huge amount of same domain accounts, whether on AWS, DigitalOcean or Google. Having to manually go into the App and try to figure which is which is tedious and dangerous for me.

RE #2: AFAIK the built-in password autofill has always been this way; it’s the main reason I decided not to use it.

I have the computer asking for my password for all sorts of things

I’m not sure why in 2021 the developers would assume that we only have one login per domain. It’s a strange choice because even casual users have more than one login on many popular sites.

I tried using the built in iOS and macOS password managers and they just aren’t up to the task. I finally switched back to 1Password and I’m very happy I did.

What were the problems that you experienced?

I think that having multiple logins at a given website will work, despite there being only on entry for the website. IIRC, there is an option to use another login when you go to that site. I can’t remember the details but the process wasn’t too onerous.

Anything is possible but I’d make my decision to use keychain or not based on what is available today.

I learned a long time ago to never tell a programmer something is simple. :grinning: YMMV

True. But it is a simple thing compared to everything else that went into the system.

Yes you can, but that’s not the problem. The problem is that there is no way to distinguish between the logins if the username is the same.

My comment was meant to be humorous, but all the programmers I’ve worked with really do resent it when a non-programmer says something is “simple” or “this won’t take very long” etc. Most hide it well, some don’t.


I can see where that would be an issue, but I’m having trouble visualizing a use case where it would occur (I’m probably being dense, it’s one of the things I do best).

My username for shopping at is with password1

My username for Amazon Web Services’ site is with password password2.

An app like 1Password lets me customize the name of these two logins so I can distinguish them. Based on @lukei4655’s post, the macOS passwords feature doesn’t allow this, so when you try to log in both of them look the same.


I’m not on Monterey yet so I haven’t seen the new password feature, but when I was evaluating different password solutions (on Big Sur) I solved this with bookmarks and, as @lukei4655 mentioned, it was tedious, and error-prone as well.

So Monterey passwords isn’t distinguishing between and

I wrote them up in this topic.

Funny, I just had a situation at work this week where even I thought the fix of a bug should be simple. But once we discovered the root cause, I see how hard and complex it was to fix it. On the surface things can look simple, but modern computers are so complex under the hood.


Oh I know. Just doubling down on the troll.

1 Like

Well, when I test it I get different things. I just did a sign on to AWS and I was able to follow which login belonged to AWS as opposed to Amazon. But this time the 2FA didn’t activate automatically so I had to go into the Passwords section in Safari to manually copy the code.

So, I don’t know whether there was a glitch when I was testing it the other day, or if there has been a quiet update. But, the last time I was testing this the 2FA automatically tried to populate the correct field, but today it didn’t. So, at this point I’ve become uncertain.