"Moving" files with Transmit

I’ve been using Forklift, and for some reason it’s eating obscene amounts of memory and causing me issues. So I reinstalled Transmit from Panic, and it seems much more stable - but there’s a wrinkle.

I can’t seem to “move” files.

I have a folder full of files on Server X that I need to get onto my local computer. In Forklift, I could just drag the items, hold down the Command key, and it would download the files and clean up after itself. Not so much with Transmit.

Is there something I’m missing? Do I need to use Transmit Disk instead? Thoughts?

I just select the relevant files, download them, then right-click to delete on the server. There’s probably an easier way, but it works fine.

1 Like

I know I can do that. Frequently though I leave the transfers unattended overnight, and I’d really like Transmit to clean up. :slight_smile:

You do what you want of course but “moving” has always been something I’ve done on a computer not between computers. It was always valuable to me to see the files in their new location before they disappeared from the old. Especially when transferring between different operating systems. My interpretation is that Transmit is just being safe.


I agree with @karlnyhus, I’ve lost files in the past during file “moves” and prefer to verify my data has arrived safely on “B” before I delete the originals on “A”.


Yeah, I’m generally in that camp as well. I just prefer it in a few limited cases because if it’s going to run overnight, I frequently forget to deal with the cleanup in the morning.

I can relate. Making sure I take care of things in the morning was the main reason I purchased the Due app. I couldn’t rely on strong coffee alone. :grinning:

1 Like

I’m pretty sure it isn’t possible with Transmit, but is this something rsync --remove-source-files could do better anyway? Transmit doesn’t help set up sync protocols directly between two remotes at all, unfortunately.

Would this help? DropSync

I stopped using Forklift after I discovered it in some way corrupted (some) apps when dragging from downloads to the apps folder rendering them useless.

I love Transmit and still use the iOS version regularly even though it discontinued years ago.


If it does what it says on the tin, that looks like it could be amazing.

Do you use the SFTP integration? If that works, that would solve my problem perfectly.

This is what scares me about any of the Finder replacement apps like PathFinder and the FTP apps that can work locally on my Mac. Apple keeps changing the underlying OS and building out the file system. It’s tough enough for the backup guys like ShirtPocket and Bombich to keep up. Must be terrible for the Finder replacement guys!


Yes SFTP worked fine

Just popping back in to say that the rsync thing worked perfectly. I now have about 5 different rsync operations going each day, and it’s really helping me get my data shoved around properly. :slight_smile: Thanks!


Thank you for letting me know. Pleased I could help :+1: