MS Exchange, Apple Mail and iOS Outlook

I’m a professor and the university’s IT doesn’t really support Macs.

Sometime between 1/24 and 1/27 something occurred with Apple Mail. I try to get inbox zero. I move emails to folders in Mail. IF there is an action I link the mail to Omnifocus. Most, but not all, mail that is in any of these folders after 1/24 is blank!
Screen Shot 2020-02-21 at 10.18.39 AM|690x445

The other thing that’s happened is that deleting an email on my iPhone or iPad (using Outlook - can’t seem to get mail in ios any other way with the enterprise single login) and in Apple Mail on my mac do not appear to delete emails from the Enterprise account. I must open Outlook on my Mac or the on-line client to actually delete emails.

I tried to rebuild, restarting, removing and then adding the Exchange account.

Any help would be greatly appreciated.


The first thing I noticed was the leading “-” and “+” characters on many of your folders. We quit using MS Exchange around 2002, but we did switch to Windows file servers after Apple abandoned the Xserve.

I discovered Mac users could get away with using some special characters in their file names, BUT Windows would have problems backing up the files etc. Exchange runs on Windows so I’m wondering if your folder names might have something to do with the problem.

I’d try removing the leading special characters from a couple of these folders as a test.


Thanks for the suggestion. I don’t think it can be the issue as the folders you saw were resident on my Mac so Windows isn’t the issue. I have moved these emails to folders in Mail on my Mac. Nevertheless I tried it and it didn’t work. Moving an email to any folder leaves it completely blank


I noticed they were local on your Mac, the first time I read your post. Then forgot it when I came back to look at the image the second time. Sorry 'bout that.

When you say you did a rebuild, did you delete the Envelope Index files from ~/Library/Mail then reopen

I’m this isn’t it, but just to say it…
My company moved from Exchange to hosted office 365, and for the longest time we were still adding the accounts on our iPhones under “exchange.” just recently, we had to delete the accounts and re-add them as an Office 365 account under settings. That made things work a lot better. Maybe try this???

I looked at the image. I have had that problem before with both Exchange and Office 365. I usually have to archive and remove from the mail database hundreds or thousands of messages before things go back to normal.