MS Word not working after Catalina upgrade

I upgraded my 13-inch 2017 Macbook Pro to Catalina last night. Today MS Word doesn’t work. I have an Office 365 subscription and checked that I am using the most current version - no updates available. It doesn’t matter whether I launch Word itself or double-click a Word doc - Word opens momentarily and then I get this:

There was a problem with Microsoft Word and your recent work might be lost. We apologize for the inconvenience.

I have tried a few things. First I did everything recommended on this page: https://www.easeus.com/mac-file-recovery/word-not-opening-on-mac.html

None of that worked. Then I uninstalled all MS Office programs and reinstalled them. No help.

I’m in crisis because I depend on MS Word to make my living. Can anyone offer any advice?

1 Like

I had sth similar and the trick with the library (https://answers.microsoft.com/en-us/msoffice/forum/all/word-for-mac-keeps-crashing-when-i-try-and-save-a/cdedc890-45e6-458b-b41d-e9634758cfe7) helped.

You can also look at this:
https://support.microsoft.com/en-us/help/2693802/word-for-mac-error-microsoft-word-has-encountered-a-problem-and-needs

Thanks for the suggestions. No help unfortunately. The problem still occurs when I boot in Safe Mode; the problem also still occurs after moving the folder com.microsoft.Word from the Containers folder to the Desktop.

I haven’t upgraded yet, and so have not experienced this issue. Have you tried using a different user account on your Mac (making a new one if necessary). This may resolve issues that are due to corrupt files in user configuration.

1 Like

https://answers.microsoft.com/en-us/msoffice/forum/all/mac-osx-catalina/718528ff-e7e4-4ecb-b42a-9fd1ba08ba5b - Microsoft support page for Catalina. One issue so far, Excel opening upside down and backwards, a recurrence of an issue reported in 2017. Yikes!

I’ve upgraded and am not experiencing this issue - one difference is that I’m on slow insiders build which is newer. Version is 16.30

Maybe you can try that?

I have also upgraded and not had a problem on my 2018 MacMini or my 2013 MacBook Pro. I have Office 365 and running version 16.29.1 (19091700) for Excel and Word,

1 Like

Have you tried install from the App Store as well to see if that helps?

1 Like

Also on 16.29.1 without Word or Excel issues here. I would suggest Microsoft support.

One issue I have noted is Teams having trouble with document uploads. For some reason the Teams is not asking the OS for permissions to access folders I think.

1 Like

Yes this is tough @ChrisClark5000 . I will state the obvious and ask have you checked “permissions” that they are set right and the information on licences etc. is correct? I think Word has to have permissions set right? I have used Libre Office in an emergency before. It worked fine and is free. However it is not always possible or advisable for security and other reasons I know. I think @Diane is on the same lines. Make sure all the ‘obvious’ things are in order, if you have already done that of course this will be slightly irritating. I have found permissions very tricky now that sandboxing is becomeing more vigourous?

Yeah sometimes it is actual glitches or bugs; sometimes it is just that permissions are not set right and user names etc. are not lined up. I now use Libre Office mind you. I know I am lucky though to be able to do that.

I had this same issue. What solved it for me was uninstalling the WordRake plug-in I had installed in MS Word. Once I did that, I had no problems.

1 Like

In a pinch you may also use the in-browser version of word as well.

I think my problem was the same and I found a workaround.

In late Dec 2019 I bought a new MacBook Air, updated/loaded Catalina then loaded the student/home version of Word, Excel (and a couple other Office apps I don’t use).

I followed suggestions on one of these boards, but all that did was change the message preventing me from opening Word or Excel files to “What’s new in Word” or “What’s new in Excel”.

Then I found that by first opening my Pages or Numbers app I could double click on the .docx or .xlsx file. And either of them opened!

I can’t “Save As” but I can create a Duplicate. Even though the .docx or .xlsx suffix still appears, I have editable/printable documents.

For the moment at least I have written off Word and Excel, will create my new files in Pages or Numbers.

Can you elaborate on this? I’m considering LibreOffice as a permanent replacement for MS Office.

Yes and no. I can’t tell you why. My reason is appalingly pragmatic. It is just straightforward I have to do what I am told. Word means Word in a lot of cases and I can’t afford to play with the stipulations. I suspect that Libre might be MORE secure in some ways: however if anything went wrong, I would be culpable. As it is I can turn round and say “I followed the rules 100%”. I know, nobody actually ever does… It is an interesting issue. Maybe somebody else can pitch in. I do use Libre a lot and its excel equivalent a lot for my own use. Partly because I just have never learnt Numbers.
I really would like to know more about what happens under the hood as it were regarding Libre.

Ok, I get it. I had to use Word at one time too, and now it’s in my muscle memory. Using LibreOffice is a little bit painful but you can’t beat the price. Thanks for your reply.

1 Like

exactly, simple as that for me. If I had time I would learn Numbers for the few uses I have of it though…