My Home app refuses to work

Ok folks. I’m extremely annoyed. Ever since “upgrading” to the new Home architecture, my HomePod mini (far and away the worst Apple product I’ve ever bought) has failed to work. It doesn’t like our wifi anymore. (No clue why.) It also tells me troubleshoot in the Home app on my phone, which I can’t do because the HomePod isn’t connected to wifi.

I have a bunch of Lutron smart switches I like to control. Those are all laggy now in the Home app. I’m lucky if they work at all. It’s been like this for months. The lights still work perfectly fine controlled from the Lutron app.

I didn’t put two and two together that this was perhaps the fault of the HomePod until the HomePod mini completely crapped the bed tonight and died on me. Now nothing works from the Home app because I have no home hub.

So how does one fix this? Can you reset the HomePod without wifi? (Is it even worth trying?) Can I have a smart home in the Home app without a home hub? (If not, I suppose I could pick up a new Apple TV to use instead, since those seem more reliable.)

I also have a Mac Mini connected to my modem via Ethernet, if it’s somehow possible to use that instead as my main hub.

Quick update: I managed to reset it, as per Apple’s instructions, even without it getting a wifi signal. But this thing is in the ninth inning with two strikes and two outs, so if it fails again, I’d still like to know what my options are. Thanks all in advance!

Did you upgrade to a new router? I have had a bunch of issues with HomePods and routers in the past. Some routers “smart switching” just doesn’t work well with them in my experience. It would switch them to a different band and it would knock them out of HomeKit. Same happened with an Asus router but I did something to lock it down to one band, which solved the problem. With a Netgear Nighthawk I could never get them to work right, and since I had HomePods everywhere I got rid of it an got an Eero and it worked great with them. (I have since swapped swapped out all my HomePods for Sonos, it just works. Also swapped out the Eero for a TP Link that I have been very impressed with.)

Is your HomePod mini in Warranty? It sounds like you got a lemon.

I have 4 with no hardware problems and one significant home glitch (when I upgraded to the new architecture) which is now resolved.

Can you set a new home hub, like Apple TV Or an iPad?

Lots of great questions! Both my iPad and Apple TV are too old to qualify for home hubs. One would need to be replaced (the Apple TV, probably, since it’s always on).

I got a new router over a year ago (from the carrier, so it’s not special, but it was faster than my Eero). I separated the bands into individual networks, so the video doorbell (the “smart” tech I needed but didn’t want) and Kobos have a 2.4ghz connection they can see. The router was set up for almost a year before the HomePod issues started. Everything was fine for that time.

The HomePod is out of warranty now, sadly. This all started with that point update that “upgraded” the HomeKit to give it Threads support, or Matter, or whatever that was.

The first issue, though, was that the HomePod started connecting to the 2.4ghz thread. But even despite that, it so rarely hears my wife that we’ve both developed spite for it in the past couple years. Just not a good product in my opinion.

It can be ridiculous. I could be standing right next to a HomePod, and another one in a different roam would react sometimes. Or none of them at all. Or if a phone, iPad, and Mac all had “Hey Siri” turned on they would all hear it, and then none actually do what I asked. Large HomePods are no better, but then again neither is my Google Tablet in it’s speaker dock thingy. All these devices can be very finicky in my experience, including Echos, which are supposedly the best at it.

1 Like

My advice for this situation…

Buy the latest Apple TV 4K model to use as the Home Hub.
Holy Smokes this solved so many minor issues for me with the Home app.


Thanks! You’re probably not wrong. Going to see if this reset fixed it, but your inclination is mine.

You cannot choose what device is your home hub unfortunately because :person_shrugging: Apple…

1 Like

Wait, what??? That’s unbelievable.

What if you unplug the HomePod mini and put it in the trash can?

HomePods, iPads and Apple TV are “supposed” to hand off Hub duties between each other as needed.

It has been my experience that the New Architecture of HomeKit works better with the latest Apple TV 4K model. Wonder if it is because of Thread support?

We have had intermittent issues with no sound when HomeKit OS 17 came out. Stereo paired speakers in the kitchen or bedroom had to be reset or restarted almost daily. Wasn’t aware that my iPad Pro was no longer a Hub until I read the above support document and replaced the Apple TV HD box. “My” problems vanished over a month ago.

From Apple?

That’s entirely expected…

Who better to decide what device is responsible for managing my “Home” than a 3 trillion dollar company which is many thousands of mile from said home.

Trust the user? What?

1 Like

Unless you have only one device that can act in that capacity, you’re still not chosing.

Tempted to mark this as the solution. Tonight the HomePod told me it’s not on the same network as my iPhone, which isn’t right. My iPhone only knows of one wifi network, and my understanding is that the HomePod only knows the wifi networks the parent iPhone knows about.

So here we are. Utterly worthless piece of garbage.

Is there anything I could replace the HomePod with that doesn’t suck? Does the Google stuff pick up your reliably? Or am I better of madly flicking my wrist towards my jaw and hoping the Apple Watch will invoke Siri?

In my experience that is the auto switching the router does, at least some routers. My Nighthawk would put the HP Minis on the 2.4 GHz when my phone was always on the 5 GHz band and it would get this exact error you are talking about. But other routers would do the same thing and it would not get this error. The problem isn’t your HP, its Home working with your router. I went through the exact same thing when I had HPs and spent a fortune on routers to try to fix it. I swapped to an Eero and all my problems with HP went away. The problem is that Eeros have great software, but the hardware isn’t great.

I have a Google Pixel Tablet dock and it is really good as a home hub. The problem is a lot of apps I use on iOS are not on Google. But it not much better than the HPs on hearing you and doing things. It has it’s own quirks though, for instance some of smart plugs (Philip Hue smart plugs) it refuses to classify as not being light bulbs. So if I say turn off all lights, it turns off the smart switches too. Little things like that.

I have one network equipped with 5ghz bands and one equipped with 2.4. Auto switching is turned off on the router itself, which is not Eero. Each network has different names, so it is not possible for the HomePod to switch to one from the other.

I use HomeKit to control my lights (nanoleaf thread/matter A19 | E26 bulbs), and use a HomePod mini as my hub. When I use the Home app on my iPhone/iPad I estimate that everything works as expected 90% of the time. When I try to control things with Siri my success rate drops into the 70% range.

@geoffaire may be right. Unless you got a lemon, my guess is your HomePod mini is probably not the problem.


Well, I’ll be darned. After considerable digging, it looks like the router is allowing the HomePod mini to use a 2.4ghz connection, even though the router claims that connection is disabled on this network.

I am… confused.