My mail app is not displaying any windows!

When I click on the app in my dock, it technically opens and is clearly doing stuff in the background (I can even see the mail shortcuts on my Touch Bar and the red badge for unread emails on the mail app icon in my dock), but it refuses to display any windows. I need help ASAP!

On the menubar select Window, then select Message Viewer.

1 Like

That unfortunately didn’t work.

1 Like

I’m honestly desperate now. I need to be able to access my email rules. I cannot do that on my iPad or iPhone.

If you trigger mission control, does the mail window come into view then? Has it maybe just got lost off the side of the screen somehow?
Have you properly quit the app and restarted or even done a complete machine reboot?

No, it says that there are no windows open.

I checked, but that doesn’t appear to be the case.

I did quit the app properly. Admittedly, I had been doing a lot of cleaning and organization in the app. Maybe that screwed something up? I sometimes have to force quit the app because it refuses to quit normally.

That is a last resort. I usually hate to reboot my MacBook Pro for anything other than software updates.

I don’t reboot mine a lot either though I will do when something seems to be acting like it’s got itself in a taffle. Standard IT trouble shooting… “have you tried turning it off an on again…” haha. :smiley:
When you say “my mail app”, is this the apple mail app or is there a third party app called “my mail”? (I’m presuming it’s the apple mail app but just to ensure there’s no confusion :wink: ).
If you right click / 2 finger click on the dock icon you should get a context menu with the option of “New Viewer Window” - is that working? There’s also a “Compose new message” option, if you can’t get the main viewer to display will it at least display the window for a new message. I’m not sure if that would help much from a diagnostic point of view but it might bump something back to life…?

Yeah, sorry. I’m referring to the default email application in macOS. :sweat_smile:

Nope! That doesn’t work.

That didn’t work either. :slightly_frowning_face:

A reboot didn’t fix the issue, but I screwed around a little more. Thankfully enough, I was able to fix the issue. Thanks for the help you guys!