My (not inexpensive) new soundbar hates my WiFi setup, which hates it right back. Please help!

I recently bought the Sony HT-ST5000 soundbar, which is quite a beast, with much excitement. Unfortunately, I have not been able to enjoy it to its optimum as it refuses to play nice with my home setup.

The issue seems to be a result of the wireless link between the soundbar and the subwoofer, as a result of which the subwoofer makes random crackling/fluttering sounds. I saw other people (who also seem to be using an Orbi system as I do) run into the issue and the solution they suggest, of turning on the Secure Link setting on the soundbar and specifying a band, helps the problem a great deal (in my case the 5.2GHz Channel 3 works best). The problem is not entirely mitigated though and I am still able to hear the occasional crackle. However, now I have a new problem, which is that every time my soundbar is powered on the WiFi on my MacBook Pro breaks down to the point where downloads crawl and it is practically impossible to surf the web.

I’ve been playing around with fiddling with settings on the Orbi (like changing the 5GHz channel, lowering the power on the 5GHz band etc.) but to no avail. Switching off the WiFi on my MacBook helps but is clearly not ideal. I am also trying to learn the ropes on the excellent WiFi Explorer app but still have a lot to learn.

I’d be very glad if someone here could provide any helpful suggestions about what I can do to resolve these issues. The soundbar seems nice and I would love to be able to make the most of it. Also, the return window closed before I had the time to notice these issues :-/ Unfortunately the soundbar and the subwoofer cannot be wired and seem to connect on RF channels 1, 2 or 3 on either of the two RF bands, 5.2GHz or 5.8GHz. I would love to know how I could amend my home network to not interfere with these. I was also wondering if the dedicated backhaul on the Orbi could be the culprit.

Here is the gear that I have:

  • Sony HT-ST5000 soundbar
  • Orbi RBK-50 mesh router (15-20 feet away from the soundbar)
  • MacBook Pro (Retina, 15-inch, Mid 2015)
  • Apple TV 4 (not 4K)

Many, many thanks for reading all of this!


EDIT: I think I may have found the crux of the issue thanks to this post by Nakamichi customer support, which is just as applicable to my Sony soundbar. It seems that the dedicated backhaul on the Orbi, which operates on channel 157 at the 5.785 GHz frequency, prevents me from using the 5.8GHz link between the soundbar and the subwoofer and forces me to use the 5.2GHz link instead, which interferes with the 5GHz WiFi network. So the main question now becomes which channel should I use for the 5GHz WiFi network (since I cannot change the channel for the backhaul)? The Orbi only offers a choice between channels 36, 40, 44 and 48 :thinking:

Thanks for the recommendation for the WiFi Explorer.

As for the channel settings and random noise, I might suggest to set the broadcast channel on devices that you can control to a value uniquely outside of any neighboring devices. For example, with the WiFi Explorer, I immediately found two broadcast devices from the local neighbors that were the same as the channel (157) for my main WiFi 5G broadcast. I therefore moved my router channel to a different, non-used channel.

As for the network slowdown, do you have Quality of Service (QoS) control on the router? If so, have you considered setting the QoS for the MBP to a higher value?

I cannot otherwise imagine what draws down the network when the sound bar runs. Are you using the new sound bar to play high-band width, 4 channel sound downloaded to the Apple TV from your router via WiFi and then streamed back to the sound bar through the router via WiFi? (just kidding … of course you have the sound bar and the Apple TV and your home 4K TV all running as WIRED not WIRELESS … right?)


JJW