Need help reversing a terminal command


#1

Hey all, hoping you can help out.

> defaults write com.apple.finder ShowHardDrivesOnDesktop -bool true

I accomplished my purpose for that tweak and now want to undo it – I figured it was as simple as changing “true” to “false” at the end, but that didn’t solve the problem. I’m not a Terminal expert and can’t find the answer–any help?


#2

According to the googles, it requires deleting the setting:

defaults delete com.apple.finder ShowHardDrivesOnDesktop

ref


#3

Setting the opposite of this is one way to do it.

If you aren’t seeing it take effect, you might need to restart Finder, or log out/in and see if that does it.

Another option would be:

defaults delete com.apple.finder ShowHardDrivesOnDesktop

Which will remove the setting from your preferences altogether, but even that may require a log out/in.


#4

Awesome, thank you! The second seems to have worked!


#5

Awesome, thank you–that looks like it worked, thanks!