Need Help Troubleshooting a Safari 17 Beachball

Safari 17 Hangs

Hi, I’ve got a really frustrating, intermittent problem with Safari, and I’m stuck on what to try next!

The Problem…

On opening a new link when there are no Safari windows, but Safari is already active, Safari will hang (complete with beach ball) for ~10–30 seconds.

Reproduction Steps

  1. Have Safari Open but with no windows
  2. Click a link in any app, open a bookmark with Alfred/Spotlight, or enter a URL with Alfred/Spotlight.
  3. If Safari opens both the link and a blank tab, Safari beach balls for between 10–30 seconds.


  • Safari v17.1 (19616.
  • macOS v14.1.1 (23B81)
  • MacBook Pro 14" (2021, M1 Pro, 32GB RAM)

Things I Have Tried…

  1. Disabling all extensions.
  2. Occurs with or without network connection.
  3. Doesn’t reproduce on a test user account.
  4. Clearing website data: Settings → Privacy → Manage Website Data → Remove All.
  5. Setting Safari as the default browser (previously BetterTouchTool was) from Settings → General → Set Safari as Default Browser.
  6. Quitting BetterTouchTool just to be safe.
  7. Restarting my Mac.

Things I have noticed…

  • Whenever the hang happens, I have noticed that Safari will open a second, blank tab. So although I have only clicked one link, two tabs open.
  • In Activity Monitor, the Safari process says it is using ~100% CPU when the beach ball happens. All the other Safari processes (extensions, networking SafariLaunchAgent etc) all seem normal.
  • Frustratingly, it doesn’t happen every time! It will be fine for 3-4 fresh links and then the problem will reoccur.
  • Doesn’t matter what URL I go to.
  • Doesn’t happen at the same point. Sometimes happens before the page loads, sometimes after the page loads. But always within about 60 seconds of the new window opening.
  • Clicking on Safari in the dock to open a new window, entering the URL into the address bar, doesn’t cause the fault.


I am a bit stumped about what to try next. Every time I think I’ve narrowed the culprit down, I manage to reproduce the problem. Suggestions for things to try or ways to narrow down the fault, gratefully received!

Hmm, do you get it with Safari Technology Preview? Also, when did this start?

There are some more aggressive resets of Safari available. (I don’t know if they’ll solve it.)

1 Like

Ok – excellent suggestions. Thank you!
I tried all the reset options, but to no avail.
I then moved to trying Safari Technology Preview without extensions. worked fine and then reinstalled and activated the extensions and it continues to work! :partying_face:

As for when it started I think it was around the Sonoma update but I can’t be sure. It took a while to realise it wasn’t just terrible internet.

I shall log a feedback now.
Thanks again.

1 Like

In case any Apple people come across this, which seems unlikely, but you never know…
Feedback is # FB13384650

I would suggest creating a new user account on the Mac and trying if the problem persists there.