Netgear Orbi broadcasts incorrect country code!

I recently purchased a Netgear Orbi to replace the hotchpotch of cheap wifi routers I was using as wifi access points. I was very pleased with the result, which has given me far stronger wifi coverage around the house, and higher network speeds without a number of glitches that used to occur occasionally with the old setup.

However, after a while I noticed a spot in the house where things (iPhone, iPad, MacBook!) seemed to disconnect from the network and have difficulty re-connecting. So I ran the Mac Wireless Diagnostics utility, which warned me of “Conflicting Country Codes”, saying this:-

“A nearby wireless router has ben detected which is identifying itself as originating from a country which conflicts with your current settings. This may prevent your Mac from automatically rejoining a previously joined wifi network.”

It then list all the networks created by the Orbi as having country code “DE” (Germany). I am based in the UK, so the code should be “GB”. The reason this is a problem is described here: http://www.mikealbano.com/2014/03/80211d-why-you-care.html

On investigation, it appears that this “shadow” area is in the point of my property which is nearest to my next-door neighbour’s wifi router, and with his router broadcasting a strong signal and the correct country code, my kit tries to connect to it rather than to the apparently foreign Orbi!

There is no configuration option the Orbi for the country where it is located, only its geographical region (“Europe” in this case), so presumably the device infers its location by other, unspecified, means - but in this case it does it wrong! There is some ill-informed discussion about this in the Netgear Community support forums, where the problem is blamed on Apple! (This is one reason for posting this here!)

After many lengthy conversations with Netgear support, I have finally managed to persuade them that a) this is a problem, and b) it is a problem with the Orbi, and c) that is not confined to a single unit - the replacement unit they sent me shows exactly the same problem.

So why am I posting this? Well, first, if you use an Orbi - and especially if you live in the UK! - you should probably run the Mac Wireless Diagnostics utility and check that it is behaving itself! Second, in the event that you find a problem like mine, do not be put off by the Netgear community blaming it all on Apple: they don’t know what they’re talking about! If you do have this problem then it would be a good idea to register it with Netgear Support, as the more people they have complaining about it the more likely they re to fix it! And third, please could you comment to this message with your results? The problem is clearly not unique to myself, and I would be interested to hear quite how widespread it actually is!

Any other thoughts would also be gratefully received.

Reset the unit to factory settings, position it close to the base station and pair it again. This should push the configuration of the base station to the unit.
While at it install any firmware updates this might help to solve the problem as well.

Return to the intended location and see how it performs. The signal it receives from the main “hub” might be to weak and isolates the Access Point. Witch in its turn might broadcast a strong wifi signal but a poor connection to the rest of the network & internet.

1 Like

Have you tried using different wireless channels?

I went through resetting to factory defaults with Netgear support, and I already had the latest firmware revisions installed. The Orbi is in AP (Access Point) mode, which means that it connects to my router (by a network cable - the router isn’t wireless!) and then provides my my wireless networking.

Netgear Support spent quite a lot of time while I uploaded configuration files, log files and screen dumps to them, and then spent a lot longer studying them all before deciding that they have a problem, so I don’t see too much point in trying to fix this: I’d done all the obvious stuff like resetting etc before I bothered even to phone them …

Thanks, but this is a modern device that auto-selects the channels it’s going to use, based upon what is permitted in the country where it is located and what other devices are located nearby, and what channels they are using. - so there is no facility to change this sort of stuff.

Is it possible to log directly into the access point and change the country settings?
Sorry I can’t give you detailed advice since I havent worked on an Orbi before. But my experience tells me that there must be a way to log directly into the device.
Find its IP address and use your web browser to access that IP address. It might get you to a place where you can administer it.
If this Ap has an ethernet port I strongly suggest use it during trouble shooting. Power cycle everything after you hard wire it to update the IP addresses…

As stated, the country code representing where the Orbi is located is NOT a configurable item, but rather something that the Orbi infers from its environment. The only remotely relevant configurable items are the geographic region (set as “Europe”) and the timezone (set as GMT). Beyond these items - and with or without their help, who knows? - the Orbi works out for itself where it believes it is located. This seems to accord with the 802.11ac standards, though the documentation I have been able to track down seems remarkably hazy on the method by which location is discovered.

As I have already explained, I have spent a considerable amount of time on investigating the problem myself, and then many hours on the phone to Netgear, who acknowledge that there is a problem and this is not merely a configuration issue. With the greatest respect to yourself, and to anyone else considering offering such advice, there seems to be little point in indulging in amateur trouble-shooting when the manufacturer’s engineers have already admitted that there is a problem and are currently working to find out what it is and how to resolve it!

Perhaps unusually, I did not post about the Orbi in search of advice, but as information for anyone who uses one, and as an attempt to see how widespread the problem may be.

1 Like

The country selection is mandatory so the various parameters are set to comply with the local laws (in the US this is the FCC).

If this cant be changed / updated I suggest to
send if back rather then waisting your (our) time to fix the bug.

I wonder if this is something related to units made for the EU market, I’ve just had a look over all the settings for my Deco and there’s no option to change the country or region at all. Makes me wonder if it’s “hard coded” before it’s shipped.

@baldbeardie, hope Netgear come out with a fix for this soon. In the short term, is it worth / can you get another Orbi node to close up the gap? If I recall correctly the Orbi is a “hub & spoke” type system rather than a proper Mesh system (although it’s marketed as such). Might mean you need to move the master unit somewhere more central.

I’m unclear quite what that means, Certainly it is mandatory that the beacon should broadcast the correct country code for the country where the device is located - “US” in the USA, “GB” in the UK, “FR” in France, “DE” in Germany, etc etc. The 802.11ac standard appears to be silent on exactly HOW the correct country code is determined, though in fact the Orbi has “United States” as one of its regionalisation options, so presumably it has no difficulty working out that the country code should be “US” if that is, in fact, where it is located!

There are individual country codes for each country in the European Union, but regionalisation on the Orbi is no more accurate than “Europe”, so clearly there is meant to be some significant pedalling going on underneath to enable the Orbi correctly to identify its country of location - which in my case if certainly fails to do! The support engineers I spoke to were, initially, incredulous that the country code being broadcast could possibly be incorrect, but given the evidence they had little choice but to accept it. I did ask, several times, whether the unit was not intended for sale in the UK, and I was told in no uncertain terms that the device is universal, and should work in all markets worldwide.

As I have already said, I did not post in this forum in search of help: I posted for the interest and information of participants here, especially those who may currently themselves be running an Orbi, and in an attempt to gain some feel for how widespread the problem is. I am sorry that you feel I have been wasting your time, but the final paragraph of my original post makes my intention as clear as I know how to make it!

Netgear deny that they make different units for different markets, and certainly the regionalisation options seem to cover the whole world! I think that the problem manufacturers have is that this kind of kit seems to get shipped pretty much anywhere in the world, so if they make a UK-only model, for example, it would give them problems if it got moved to Italy! It is cheaper to manufacture a universal model and - in theory at least! - will cause them less support hassle! The 892.11ac standards document refers to a library routine that establishes geographic location, although I have been unable to find any documentation on how this functions. However, it is known that quite accurate geographic location is possible using signals from surrounding wifi equipment (If I turn off wifi on my IOS devices I get a message about geo-location not working properly!), and my iPad with wifi turned on seems able to work out where it is quite accurately simply by looking at surrounding wifi beacons, even though it has neither GPS receiver nor cellular connection!). I therefore assume this is how the Orbi and other devices are meant to locate themselves nowadays.

Thanks for the suggestion about moving another Orbi to close the gap. I do in fact have an Orbi satellite unit, but it is currently filling in a much more important hole in my coverage, so I am reluctant to move it in this instance: it’s easier to just be a little more careful where I put my wifi-connected equipment! :slight_smile:

Location info without using GPS seems a bit hit or miss, I’ve noticed that when various web sites try to auto-detect my location it can vary wildly. Not sure if my ISP messes about with settings or something as some days the same site can think I’m located where I actually am; in the next city or sometimes right down the other end of the country. :roll_eyes:

I perhaps wasn’t clear on what I meant about moving the master unit.
My suggestion actually was if it worth buying another additional satellite unit to complement the units you already have? (I believe it is possible to have multiple satellites with the Orbi system though I’d double check your specific model number as there seems to be a confusing array of them). A word of caution though: I believe the Orbi system is not a true mesh system therefore you cannot have the main unit at one end of the house with a node in the middle to bounce the signal to a node at the back of the house. You would need to position the Master Orbi unit in the middle of the house so each satellite node is within range of the master unit. The Orbi is a “Hub-and-spoke” or “star” type system.

This is one of the reasons why I went with the Deco’s rather than the Orbi: incase I ever needed to “Daisy chain” multiple nodes to get the signal to where I needed it. (As it happens; I get sufficient coverage with just 2 units: a master with one satellite.)

Hope that all makes sense.

The manual suggests otherwise. Under “Specify Basic WiFi Settings” there is a step starting with “To change the WiFi channel, select a number in the Channel list… Do not change the channel unless you experience interference…” which is what you are getting from your neighbor’s router.

My apologies - you are correct, it is possible to select the channel rather than letting it be selected automatically.

That said, I don’t really see how that is going to help. Leaving the channel selection in automatic mode means that the channel in use can change dynamically (I’ve watched this happen using Wifi Explorer) so that the link is always via the best available channel at that time. In any case, my problem is not related to the channel in use, but to where the device thinks it is!

Your neighbor’s router is transmitting data, including the country code, on the same channel that your router is using. This is interference. By changing channels your devices will no longer “hear” your neighbor’s router - including the country code.

Your neighbor’s router is transmitting data, including the country code,
on the same channel that your router is using

Actually, no. His router and my Orbi are using different channels (presumably because of automatic channel selection). AIUI data transmission and the router connection protocol are separate functions of a wifi interface, and they don’t (or don’t necessarily!) share the same radio frequencies.

1 Like

Just to add to the conversation: I’m having the same issue with a Netgear Nighthawk R8000. It transmits as DE, and for the first few weeks I had huge trouble connecting. My iMac and iPhone refused to connect to the network most of the time, and occasionally it would work. I have raised to Netgear Support who appear to be getting no-where on the topic - nothing useful so far. The issue seems to have lessened but given the issues I had I don’t want to chance it so as I’m still in my amazon return period I’m going to send it back. Thank you for your input - I was thinking of getting a different model, but sounds like this is a Netgear issue across the board, so will go with another brand…