Never ending indexing: mds* processes constantly running 2 cores at full blast

This has been an ongoing issue with my 16" M1 Pro running Monterey. Whether I’m mobile and untethered or at home connected to a 7 drive JBOD, there are a variety of mds processes occupying the entirety of two cores, as per iStat menus:

Screen Shot 2023-09-01 at 12.30.23 PM

I haven’t kept a record, but I’d say it’s running this way 95% of the time. Neither my boot drive nor any of the HDs or SSDs in my JBOD are being modified even remotely frequently enough to require this incessant indexing. I expected a lot of required indexing when I first got the MacBook, but that’s been over a year and for quite a while now, the indexing has been running rampant. I do run Time Machine regularly (in addition to Backblaze and less frequently CCC) but again, there aren’t that many updates. Adding drives to the privacy list doesn’t help (Time Machine can’t be added to the privacy list anyway), disabling Spotlight via command line only prevents me from opening apps from Spotlight - the indexing apparently continues, as cores 1 and 2 remain lit up basically all the time.

I’m a late adopter for OS - I’m usually a couple full updates behind, as in the “if it ain’t broke, don’t fix it” mentality. But if updating to the latest Ventura release can help here, then I’d gladly update. I’ve tried the handful of work-around “solutions” I’ve found while surfing but none of them seem to do the trick.

I’m going to assume this isn’t normal so I’d like to correct it - I’m sure my older Macs didn’t do this, pre Monterey - so any ideas would be welcome. Thanks!

1 Like

What is a JBOD and mds*?

jbod: just a bunch o’ discs
mds*: the spotlight indexer (processes like mdsworker)

This seems to be one of those things that happens from time to time. In my experience, it usually goes away on its own, though it can last a few days.

I’ve found it usually occurs after an OS update.

I noted that this is happening maybe 95% of the time, and that I have not updated the OS. Obviously that’s not the issue, and the “oh well” approach isn’t the way to go.

I’ve learned elsewhere that the spotlight index can become corrupted and cause the issue I’ve been experiencing, which is the mds* functions running constantly. What I did not try was to add all of my drives, including the boot drive, to the privacy list in the spotlight settings. Then, after removing each drive from that list, Spotlight reindexes it and apparently clears up any corruption. I did that a couple hours ago, and my cores continue to run at a low level since there are no mds functions running anymore.

Except for the Time Machine drive. For whatever reason, that drive is blocked from being placed on the privacy list, and thus the index cannot rebuilt. So guess what happens when that drive is mounted. Yep, the mds processes flood the activity monitor again, and core 1 & 2 go full blast. As that info is in short supply here, I’ll keep searching - I hope someone somewhere has solved this before.


Whenever I’ve tried to use TimeMachine, I’ve had either this same problem, or TimeMachine errors, or – and in a way this is the worst – had TM act like it was working but discovered that it hadn’t actually been backing files up.

For these reasons, I left it behind years ago. I use Arq to back up to Wasabi (cheaper than Amazon), and use Carbon Copy Cloner to save incremental snapshots to two separate external drives. I also make the occasional clone to yet another drive, just for fuzzies.

Life got much happier when I ditched TimeMachine!