New iPad not showing up in Finder sidebar

New iPad conversion going ok. I was able to connect it to iMac running Catalina and transferred calendars and contacts via the info pane as suggested for those of us who will not use iCloud.

As part of my weekly review I always sync contacts and calendars off my main iMac to my portable devices. That worked once but not anymore. Now even after a reboot, the iPad shows up in the finder, I click on and then click on info to try to do this again as a sync. There is a spinning and then the iPad is removed from the sidebar and I can’t get it back or at least I can’t figure out how to get it back.

Everything I find assumes you are trying to use iCloud and nothing is offered about sync without using it even though it worked once. I can’t find anything about how to debug the iPad not showing up other than check cable (not applicable, I am using WiFi). I have verified that iPad and the iMac are on the same WiFi network. Finder preferences are set to show CD’s, DVDs and iPods in the sidebar and also show Cds, DVDs and iOS Devices in Locations.

I’ve tried turning those features off, rebooting then turning them on again and rebooting and still no joy.

I can use iMazing to copy contacts from my iMac to the iPad but it’s not a sync and if I’ve made any changes on the iPad I have to remember what I changed and not overwrite it.

iMazing does not work for calendars that way.

You didn’t say how you ‘connect’ the computers. If you’re doing it by cable and are having problems try connecting by Wi-Fi.

I’ve tried both. It never showed up via cable but I did get it to connect via wifi once but no longer.

Look at my 3rd paragraph

PS I have also verified that my Home Director has my username with proper permissions applied to enclosed items.

I was considering deleting the finder.plist but upon checking there are 15 files. All but one have additional characters on the end and appear to be backups as the dates on them are older but not sure so didn’t delete anything yet.

If you have iMazing installed, it may be derailing Finder’s discovery of the iPad.
iMazing’s hacks prevented me from doing a backup to my computer in Finder, even after I deleted iMazing.

So, I made sure nothing on iMazing was operating but that didn’t work. However, I ran the change permissions on my home director again on all enclosed items and it took a lot longer than before, about an hour, and then I rebooted my iMac and now I can see my iPad in the finder. :crossed_fingers: it will continue to work.

1 Like

Do it I won’t. That way darkness is.

1 Like