New iPhone, can't send text message but can rcv

Tried, turning on and off airplane mode, verified that I have a cellular data plan, tried to turn off and on the phone competely and I’m stymied.

Brand new iPhone 13 Pro, I can receive text messages but no matter what I try I can’t get them to send. I have both a Primary phone and cellular data plan listed with my phone number as per normal.

But on the new phone the separation of cellular and voice is more obvious.

I have probably set something wrong and it’s not going to the right service but I never had to choose a service on my old phone so I’m not sure why I’m getting this now.

I did successfully trasnfer all my old phone data, contacts. message hostory and more when I activated it and I can send and rcv voice calls.

Sugestions on where to look toe fix this?

I’m sure it’s a stupid user error but the help I’ve found on-line doesn’t match with what my options are on this phone.

Does Reset Network Settings fix it? As of 15 it’s in General > Transfer or Reset > Reset > Reset Network Settings.

I think I’ve seen odd situations like this on occasion when moving a SIM card to a new iPhone on AT&T in the U.S., without also notifying AT&T about the switch. Nor sure if any of that is applicable for you.

I’m on T-mobile and it’s showing up properly on their system the re-activation was lengthy but appeared to go properly

If you swapped the SIM card from your old iPhone, that can cause these type of problems depending on the age of that SIM card. You may need to just visit your Carrier and have them activate a new SIM. I have seen this work for customers in the past. Carrier states they “see” your data service but replacing the SIM actually fixes the issue.

1 Like


Got issues fixed. Problem is that T-Mobile’s website saying to move the SIM card to the new phone is in error for iPhone 13’s. They do have a SIM slot but their preferred mode is the eSIM and that was causing a conflict. Take out the SIM card and it all worked.