New SSD not seen - can I clone to it?

Dear all,

here’s another episode of my Macbook Air love saga.

Those who have read my messages before will know that I currently own:

  • a 2012 11" Macbook Air (1TB, 8GB)
  • a 2015 13" Macbook Air (512GB, 8GB)

The 13" was actually meant as a temporary replacement for my 11", which I still find very handy to carry around (I have a 27" Thunderbolt display at home), while I upgraded it from 500GB to 1TB and ran a few tests (loud fan).

I have now decided to buy a second-hand 2015 11", which came with a 256GB SSD and 8GB RAM. I’ve tried it, it worked (it had Catalina on) and it seemed quieter. I have now replaced the SSD with a 1TB from OWC and I can’t get it recognised in recovery mode. Command-Option-R gives me a 5101 F error and Shift-Command-Option-R gets me to disk utility with the option to install El Capitan (10.11), but the SSD is not seen. I know these SSDs work from 10.12 onwards, provided the computer had at least High Sierra installed before (it did), so that it could get its firmware update. However, internet recovery won’t find me anything more recent that El Capitan.

If I start it from a clone (from the 13") I can see the SSD and I have reformatted it in APFS. Was that a mistake? Internet recovery gives me the same results as before the reformatting. Should I have stuck to Mac extended, installed El Capitan and then reformatted to APFS for High Sierra at some point? I’m a bit confused.
I know there’s the option of creating a bootable High Sierra installer (that is as far as I want to go), but it didn’t work (I will try again though).

I’m also wondering if I could just dump the whole clone onto the SSD (by using the clone as a startup disk and cloning onto the SSD with Superduper) or without a proper installation (the SSD is empty now) it will act up eventually?

I hope my message was clear enough and apologies for perhaps asking very basic questions.


Is the SSD from OWC new? If so I would contact their support.

Yes, new. I’ll write to them. I thought I’d ask first in case I have missed something fundamental.

People have been having similar problems, but their solutions haven’t worked for me so far.

Some aftermarket drives aren’t compatible with internet recovery. (Perhaps all of them.)
I got the same error with my Fledgling drive in my 2015 MBP, and wound up putting the OEM drive back in, as I didn’t need that much space anymore, and wanted to simplify recovery.

OWC told me more or less what I knew (firmware, recovery mode, bootable USB stick). Since all other options failed I went ahead and cloned to the new SSD. So far so good, hopefully it’ll stay that way.

By way of information, I have read somewhere, as I was researching the problem, that cloning software may not copy the recovery partition over, something to keep in mind.

Did you make the clone the startup disk and boot from it – to be sure it works?

Yes, I did that first. Then once I saw it was working, still with the clone as startup (I wouldn’t have had anything else to start up from anyway), I cloned it onto the new SSD with SuperDuper.

Did you end up with a valid recovery partition?

Haven’t checked. Do I need to start in recovery mode to see if it’s there or is there another way?

You can see whether you have a recovery partition (actually, a volume) with this terminal command:

diskutil list apfs

but AFAIK the only way to see if you have a valid recovery volume is to try starting up in recovery mode.

response: Could not find disk for apfs


diskutil apfs list

Ah, thanks!

Ran it on the 2012 11", which had a clean install of High Sierra after the SSD change and it has it. It actually says it has four volumes:

disk1s1 (No specific role)
disk1s2 (Preboot)
disk1s3 (Recovery)
disk1s4 (VM)

Currently reinstalling High Sierra on the 2015 11" (I hope you can still follow which is which, this is the latest one, the “successor”! :slight_smile: ) after entering recovery mode with cmd-R. I hadn’t checked if there was a recovery volume in disk utility, but it didn’t go into internet recovery so I suppose there was). I’ll run the command in Terminal again when it’s done.

No experiments on the 13", which is itself a clone, so it may not have it, since that’s my main machine for the moment, until I’m fully satisfied that the “new” 2015 11" is working without fault. Then maybe I’ll trade in one (possibly two) of the remaining machines.

High Sierra reinstalled, recovery partition is there.

It must have been there in the clone too, I think that used to be a problem in previous versions of SuperDuper.

Sidenote for future reference for anyone looking for info on this.

I have changed my SSD again (2TB this time) and I made a rookie mistake: I did not reformat the new SSD to apfs. Surprisingly, SuperDuper still copied the clone over (High Sierra is not supposed to run on HFS+), but understandably the recovery partition wasn’t there.

I have reformatted the SSD as apfs, cloned my disk over again, now it’s all good. Even though the external disk I used for cloning is formatted HFS+.

Here’s a very useful post kindly provided by the developer of SuperDuper:

Edit: High Sierra does run on HFS+. SSDs are automatically reformatted to APFS when upgrading to High Sierra, but since what I did was cloning no automatic reformatting occurred.
Spinning drives are left alone and di not automatically get reformatted to APFS.

1 Like