No longer possible to use separate Apple ID for App Store on Mac, help

Since 2009 I have an ‘iTunes account’ which I use to purchase almost all apps and subscriptions. Years ago I had to change it to a proper Apple ID (i.e. an email). I kept using this Apple ID for all purchases and shared them with my family members.
On my iPhone and iPad(s) this continues to work, but since a few weeks I cannot get it to work on my Mac (macOS Monterey). Apps on the Mac will no longer update and I cannot log into the Appstore with my separate Apple-ID.
Today I’ve jumped through several hoops to add my iTunes account to my family so I can keep using the purchased apps but even though the ‘family member’ is added, and I managed to share its purchases, I cannot update my apps.

Any ideas how to solve this? I don’t want to spend hundreds of dollars repurchasing everything I already bought.

Also, any ideas on how to go forward? Should I keep the separate account for purchases or not?

While it of course not solves your problem, it is still working fine on my mac, so it seems to be not a general occurrence.
Where exactly do you enter the ID?
Is it possible, that there is a Typo in the ID, or the Password?
Could you lock into your ID-Account via this Website?

Thanks for verifying that nothing had changed except my configuration.

I‘ve tried many things: rebooting the phone, rebooting the Mac and nothing worked. I then logged out of iCloud on my iPad mini and logged in with my store account, nothing odd. I decided to add the store account to the family sharing as a separate member. That didn’t solve the initial problem and I got questions from the kids that some apps were not available anymore.
Finally I dropped the store account from the family and I went through all the settings in my phone and somehow was able to add the store account back as second account. Looks like it is solved now.

1 Like