"Not connected to the Internet" messages

Our 5-year-old house came prewired with Cat 5 to a panel in the basement. Our CenturyLink ISP connects to their router there. Service is 40 mbps down, 20 up, and Speedof.me tests show we routinely get around 45 mbps.

Every few days, my wife’s 2018 iMac gets “not connected to the Internet” messages and delays when using Safari to read her Yahoo mail or play Facebook games. After a few minutes, the message goes away and data flows normally.

My Mac’s in the basement, connected via a Netgear Powerline that runs data through the electrical wiring, getting 46 mbps, and I never get these messages.

She’s connected directly to the Cat 5 system on the ground floor, via a flat Ethernet cable, about 20 ft. long, running under the baseboard because her desk is on the opposite wall from the wall socket.

Last night, after all Internet use was done, I did speed tests using both speedof.me and CenturyLink’s speed testing website, and all looked pretty good.

Because I suspected the flat cable, I ran tests with a MacBook Pro using that cable, and also going directly to the socket with a normal 6-ft. cable. Both tests, on both websites, got around 45 mbps. CenturyLink’s test showed”ping” of 4, while Speedof.me showed “latency” of 33 with the flat cable and 14 with the normal cable. (Are ping and latency synonyms?)

(The Powerline only got 15-18 mbps from her work area, but she’s farther from the router than I am in the basement, so that makes sense.)

Could something be wrong with her iMac that would cause it to lose connection (or think it’s lost connection) intermittently? I ran the Hardware Test and it found no issues.

Of course, good data speed doesn’t mean some connection’s going bad, then fixing itself after a few minutes. But wouldn’t that be a wire that’s barely making contact somewhere, and wouldn’t that affect speed all the time?

Could the CenturyLink router be malfunctioning? We’ve also had recent buffering issues with our Roku stick. Two nights ago, I restarted the router, and immediately all was fine. Unfortunately, my wife also turned the Roku off and on, so I don’t know which rebooting fixed the problem. The Roku’s in a spot that tested 44.5 mbps last night. (This wireless Roku may be a separate issue, since my wife’s wired iMac trouble has been going on for many months.)

Mac? Wiring? Router? What (and how) should I be checking?


Try switching your Mac with your wife’s temporarily, that could give you an idea whether the problem lies with her Mac.

To check the wiring, get another Ethernet cable and connect it instead of the existing cable.

If neither of those make any difference, ask CenturyLink for a new router.

RE your Roku, check your wifi for interference.

Does she use a VPN? I’ve had that error when my VPN client is trying/failing to reconnect.

1 Like

Sounds like you’re getting all the right ideas on where to troubleshoot. I would add it could be the port on the mac. You can test by using a usb to ethernet adapter.

Also, where are you using powerline?

No VPN, just a normal connection to CenturyLink.

I use the Powerline in my basement studio, which was not pre-wired with Cat 5 when the house was built. Since I’m within 30 feet of the Powerline receiver, which is right next to the router, I get great speed. I tried it on my wife’s upstairs setup just to see if it might be a way to bypass the Cat 5, but it’s much slower from there than when I use it in my studio.

Switching for a few days is a good idea. And another cable, too. As I said, a bad cable could work normally, with high speeds, until it doesn’t work and the connection is broken.

After a couple of evenings of good service via the Roku, last night it buffered once for about 10 seconds. I immediately ran speed.me from my iPhone and got about 30 mbps, but the slowdown could have just lasted 10 sec. Are 10 second wireless slowdowns normal performance? I may have not ever noticed, since the Roku is our first use of wireless for TV viewing.

All other things being equal, I would say it is not normal, but it’s hard to tell whether everything else is operating nominally over such a short time period. Unless you live out in the country (I.e. no neighbors) I highly recommend checking your wifi for interference.

Yes, I would agree that slowdowns in a lightly used environment should not be normal but there could be other factors outside of hardware and wiring. For example, are you running online backup to a cloud service? That might cause a slowdown. You also said that rebooting your router fixed an issue with your Roku. It is possible that you have an IP address conflict with one of your devices. When rebooting your router, you can also reboot your other devices on your network to ensure they get new IP assignments from the router.

If it’s not a logical (IP addressing) issue, start eliminating one hardware component at a time.

The easiest to replace is the flat ethernet cable. Try using a round ethernet cable from the upstairs iMac to the RJ45 jack in the wall - those are less susceptible to EMI. If the problem continues, then try a USB-Ethernet adapter as mentioned above. If the issue still occurs then you’ve eliminated the Mac’s ethernet port and the cable to the wall and you can check the following:

  • RJ45 wall jack upstairs - is it loose? Can you remove it and check the wiring behind it?
  • Cat5 wiring panel. Is the wiring coming from upstairs well connected? Do you have a patch cord from the panel to the router ? Is that loose? If so, you can try moving the connection to a different ethernet port on the router if one is available.

Let us know how it goes.

We’re not doing any online backups, but restarting devices is a good idea. Do you mean rebooting everything (wired or wireless?) that has ever connected to the router? iOS devices, my Airplay adapter, etc? Is an IP address conflict due to the router assigning the same IP address to different devices? Why/how would it do that? Could I look at the router admin screen and see what it’s assigned to which devices to check for conflicts?

And thanks for the suggestion to check all the connection points. I’ll post what I find in all this.

Assuming you have only one router, this should never happen unless you have assigned a static IP address to some device and that address is within the range that your router’s DHCP server uses to assign addresses to clients.

Yes, you should be able to do this.

1 Like

No, I’m not doing anything that fancy. Pretty much straight out of the box for the router. I’m now trying a USB-Ethernet adapter to see if my Ethernet port’s bad. If that doesn’t solve the problem, I’ve got a normal, thick Ethernet cable I’ll try, in place of the flat one running under the baseboard. I’m trying everything possible before buying a new router/modem, where I’ll probably be stuck with the same, several-years-old design CenturyLink offers. (2.4 Ghz only)