Notifications are quiet…too quiet…

My battle with perpetual, unannounced and un-indicated DND on my office M1 Mac mini running Monterey is at an impasse. It doesn’t say it’s in DND (or any other Focus mode), but all notifications appear only in Notification Center: no banners, no alerts, while the Notifications & Focus preference pane says I should be getting those.

Force-quitting Notification Center via Activity Monitor doesn’t resolve the issue. Any ideas on how to nuke the notification and DND settings on a deeper level (Terminal, Libraries, whiskers on kittens)? My home M1 Mac mini handles it all fine, with the same configuration—something just seems to have gone sideways on this particular machine…

I’m having the same issue across all my devices running the latest OS on each. Notifications are sporadic at best but the majority of time just show up in notification with no sound, banner or buzz. Like you I am running no focus mode or do not disturb. I’m guess this is a bug of some sort and will eventually work itself out. It’s tough to figure out since focus modes are now synced across devices so you’re not sure if one of your devices is the issue or something else is going on.

1 Like

Found the answer to this! I use an iPad Air as a second screen using Duet, and it looks like Monterey added a checkbox I needed to check: at the very bottom of the Notifications & Focus panel of System Preferences, the Allow Notifications: When mirroring or sharing the display checkbox did the trick.


1 Like