Old WD My Passport for Mac Not Showing Up In Finder

My daughter has been using a very old WD MyPassport for Mac (circa 2018) and all of a sudden (month or so ago) it stopped showing up in MacOS finder on her MacBook Air. She brought it home from school and I tried it on my iMac and same thing. It doesn’t show in Finder. I do have Western Digital software ('WD Discovery 'and ‘WD Disc Utilities’) because I have other WD external drives attached to my iMac. And those apps are able to ‘see’ her MyPassport Drive, but they will not enable me to open it up and see what is on the drive. Also, it is an ‘old style’ disc, so when I have it plugged into the USB port, and I put my hand on the drive, I can feel it vibrating and spinning. So something is happening in the device.

I’ve tried Disc Utility, I’ve tried rebooting machines. I’ve tried different USB ports. I’ve spent 30 minutes chatting with WD Customer Support. Assume I’ve tried all the basic approaches. The weird thing is that it does not display/show up in MacOS Disk Utility at all.

Anyone have any suggestions of apps or approaches that may be able to get this to work? All we want to do is see what is on the drive and move its contents to a new SSD we got for her.


I’ve noticed that external drives can occasionally take a long time to mount on Catalina and newer versions of macOS. I seem to recall this is because macOS now does a lot more checking on drives that were dismounted improperly. If all else fails try connecting the drive and let it run several hours. If the drive is mechanically sound it can’t hurt. (You don’t hear a clicking sound, correct?)

If you absolutely had to get data off of this drive I’d suggest SpinRite. It runs on DOS so you’d need access to a PC to use it, but it works on literally all operating systems. I’ve seen it recover drives when every thing else in my bag of tricks had failed. But it’s $90.

Probably not the issue based on what you have said, but I’ll say it just in case.

I have some drives that do not show up in Finder if I plug them directly into my M1 MacBook Pro. If I interpose a cheap USB dock, then they work fine. I do not know why this is, but it’s a thing. The main one I can recall that does this is a WD My Passport Wireless Pro. If I plug it in directly, it stays in wifi mode. If I plug it in via the dock, it drops wifi and switches to storage mode.

I will try leaving it connected for several hours. I am not hearing a clicking noise so that is a good thing!

Thanks for the software recco.

@zkarj Interesting you say that regarding plugging it in directly to iMac USB port vs. trying a USB dock. I have a dock and I tried both that and plugging it in directly to iMac and I saw no difference.

(1) Try it on an old Mac

(2) Try it on a Windows PC


Try using different USB cables. Since your troubleshooting steps mentioned different USB ports you probably tried this, but it’s worth mentioning.

The cables provided with those ubiquitous 2.5" WD Passport and Slim Seagate drives are notorious. I have had two of them fail.

Those USB cables are cheap. And they are worth it.

You are smart to use an SSD going forward. I have had good luck with Samsung T5/T7 SSDs and Sandisk Extreme Portable SSDs. The cables provided with the T5 and T7 SSDs are excellent. The cable provided with the Sandisk Extreme Portable SSD is also good, but very short (6").

Bombich Sofware’s (Carbon Copy Cloner) Knowledge Base website contains an excellent article on choosing backup disk drives:

Good luck. Please post back if you find a solution.


I’ve had the ‘old’ HD connected to my iMac for a couple of hours and it still has not appeared in Finder yet. I’ll leave it connected overnight and see if anything changes. Otherwise, may give up on it.

You can see a version of the ‘old’ HD here on eBay (not mine but this is it):

The cable it has is an old USB 3.0 flat Micro nib type thing. You can kind of see it in the eBay listing above.

The SSD we got is this one - 2TB in a drive the size of a credit card. That little thing has the same capacity as my iMac! It is amazing! So fast!

Are you connecting it directly to the computer’s USB port or are you using a USB dock or USB splitter?

I recently sold a 1TB T5 to a friend when I got a 2TB T7. Those suckers are fast and reliable. Although when testing it out for my friend I was surprised just how fast the internal SSD is on modern Macs. The externals are still wicked fast but the internals are eye watering. The external is completely pocketable and weighs basically nothing.

I’ve not tried the SanDisk SSDs but I have trusted their SD cards for many, many years in my camera. a Solid (ha!) choice of brand.

Absolute worst case, if the disk is spinning up, the disk may be fine, but it may be a problem with the “caddy”

You could extract the hard drive and plug it into another caddy to see if the drive is fine.

Definitely try this before you spend any $ on anything! I didn’t try it with a WD but with a Seagate that wasn’t appearing on my Mac; it works like a charm:
Plug the EHD into another type of computer (I used a Chromebook, but Windows would do) - it will appear on the desktop there.
Then eject it properly, and plug it back into your Mac. It appears perfectly fine on the Mac desktop! (I’ve done it about 6 times with that same Seagate and it works every time.) Hope this helps with your WD!

I’ve tried both with no difference in either approach.