One last effort before I fire Centurylink and risk ending up with worse

Yes, I’ve tried working with them. In my OP I wrote, “So, I got back on the phone with Centurylink a few days ago, after switching back to their old router so they wouldn’t just tell me to call Archer and the connectivity issue happens with both routers. They ran a “test” on their router and said there were signs it was failing, offering to sell or rent me something from their current line.”

I’m trying to see if I can get my perfectly good Archer unit to work without the interruptions, and avoid buying another new router from them.

Yes, it’s fiber, with a Calix 711GE ONT, all connected as your first paragraph describes. Issues definitely with hardwired, and that’s what Ive been testing, to remove the variables wireless introduces. Not sure if same issues with wireless (that would just be my phone and I don’t do long sessions.)

I tried connecting directly to the ONT, but got no signal with our old MacBook Pro. I’ll try again, as I know it should work. Since the problem is intermittently dropping the connection, and really not speed, it will be hard to “catch” it misbehaving as I sit by the side of the house… it could be hours. Idea: my wife’s iMac isn’t too far from the ONT. I’ll see if I can connect her directly to the ONT with a long cable I have.

And thanks for your roadmap for progressively diagnosing.

Single-family home. No multi-family anywhere nearby.

Thanks. It makes sense now. My Converter Plus iPhone app confirms!

1 Like

Most of the way I would check, if there is a failure within the equipment was already written, so I only want to bring in one another thought into that discussion.
Just because something is called “digital” or “fibre” or whatever does not mean necessarily, it is flawless!
To have some dips in your connection is rather normal, then a real problem. It might be annoying, but you will not solve it, if it is not a real technical malfunction.
We tend today to the expectations, that everything has to run on “100%” “24/7”, but in reality this is pretty seldom the case.
To observe some ditches in your downloadrate could have a ton of different reasons, all pretty normal, and you will not be able to change that.
It could be possible, that there are within that moment not more informations on the way to you, it could be a slow connection on the server side, it could be, that your IP is shared with a lot of other people in the same street, building, area or whatever, and the more sitting in front of their computers or are streaming, the less data are received by every individual on that line.
And even if you are the only one on that line, there could be other reasons for “problems”. E.g. an other app is requesting or downloading some data, while you are playing your arcade game, or someone in your household is using the internet too, and so on.
I, of course, don’t know exactly, if you really have a technical problem, or not (therefore do the tests recommended in this thread), but we should in general (NOT only you!) become mire relaxed with issues like that, as in most cases, there are reasons beyond our control, and in many cases also beyond of the real control of someone else.

From what I see on the graph, you have a pretty stable connection.
BTW: “40GB fiber plan”?
Does that mean, you can use only 40GB per Month on that plan?

Thanks for putting this in perspective. Yes, speed can be quite variable, and I expect it. But the real problem is “you are no longer connected to the internet” messages, and then programs or web pages crashing or freezing. Being tossed out of online games over and over. Not just slowing down, but stopping for 30 seconds to several minutes. iStat Menus says “0.00 MB/s” A few weeks ago, I tried for days to download Catalina to install on an old iMac, and it always failed.

So those big dips in the graph every few seconds is normal?

And my mistake on our internet plan. It’s 40Mbps, not 40GB. The amount is unlimited.

Thanks for taking the time for the detailed response. I do appreciate it!

I didn’t want to get into this as it can get VERY involved, but I disagree with this completely as a former Infrastructure engineer. To hit this problem occasionally with a particular service / endpoint may suggest a problem with something on their end, but a regular drop to zero throughput for all traffic on an internet connection multiple times a day means that there is a problem somewhere from the computer to the ISP.

To have a fight with your Internet provider you first need to rule all of your kit out.

Here’s the path I would follow, if the step doesn’t remove the issue, continue to the next.

  • If this happens on multiple devices, you can usually rule out the devices as an issue.
  • Next step would be to hard wire a device to your router via an Ethernet cable and test (If this stops it’s probably a wireless issue)
  • Next step connect directly to the endpoint (i.e. only one device, remove your router) from the ISP and see if this stops the problem (If this stops it, probably a router issue)
    If you get to this point and you’re still having problems having ruled all of the above out, put everything back.

Now run a traceroute/tracert to an internet IP address e.g. 8.8.8.8 and make a note of every IP Address on the way
Then run continuous pings to:

  • 127.0.0.1 (Your local computer)
  • Your local Router Address e.g. 192.168.1.1 (The 2nd address you get)
  • Your ISP modem (the 3rd address you get)
  • Your ISPs Router (The 4th address you get)
  • 3 different internet addresses e.g. www.bbc.co.uk, www.google.co.uk
    When you have an outage, see what stops responding. If your router still responds, then whatever is causing problems is beyond your router, if your Modem still responds, then it’s beyond that and if your ISPs router responds, then it’s not a problem with the line.

I had a similar problem with my ISP 18 months ago (Virgin Media in the UK) where they claimed nothing was wrong despite an outcry and thousands of people complaining to them on social media. I was able to fault find exactly where in their network the connection was being lost and they still wouldn’t listen. I’m no longer a customer.

5 Likes

As probably not everybody is aware, of how to run traceroute on a mac, here is some advice.

1 Like

:yellow_heart: That’s why I didn’t want to get into it. It’s hard to talk someone who may not be technical through doing these sorts of things.

1 Like

Good suggestions, I didn’t think about running ping to all the intermediate points.

One possible problem could be short power glitches. Just enough to affect the ONT but not enough to affect all the other components. I keep all my network gear on a UPS so I maintain connectivity in a power outage. I have a backup generator but it takes about a minute to come online.

We need to start a pool on where we think the problem lies. My bet is either the ONT or the net node downstream.

1 Like

I’ve seen issues at work where it’s been a dodgy Ethernet cable in a server room (I.e. never physically touched) these things can be so hard to pin down when they’re intermittent.

1 Like

If you are only getting 50% of the rate and it drops out frequently, you don’t have a good deal at all. My experience here with fiber is that it hardly droops at all during high demand times since you have a dedicated line to the central office. It looks like Century Link hasn’t upgraded their service to their central office to carry the traffic.

Experience around here is that cable is inferior to fiber. If it is available where you are, you might want to try out one of the 5G home services.

I just checked out speedof me and see the same sort of dropouts that you have, but these are all short term and shouldn’t really be causing a problem. But the speed you are getting is terrible for what you are paying for. I have 50Mbps service with Ziply Fiber (formerly Frontier, formerly Verizon) and get what I’m paying for:
SpeedOf_Me___Internet_speed_test_for_all_devices-2

The brief dropouts happen on multiple hardwired devices (2 iMacs and an Apple TV). Our house was wired when built (Cat 5, I think).

I’ve been told I can connect a laptop directly the ONT on the side of the house. I tried it a month or two ago and couldn’t connect. I’ve recently realized that might require the PPPoE login like the router uses to connect. If so, how would the Mac handle that when directly connected to the endpoint?

If I can get that working, I have a 25-foot cable I could run out the window and plug my wife’s Mac into the ONT. She’s on the net more consistently than I am, thus a better scanner for dropouts.

With my 40 GB (fiber) plan I usually get 37-38 GB on speedof.me

It’s the dropouts, not speed. I get zero for 30 sec. (enough to break downloads and some web page activities) OR 37-38.

I’ve recently noticed they’re offering 200GB for $50/month, so my plan’s out-of-date. Maybe switching to the “current” plan would get me around whatever roadblock I’m now hitting? But again, It’s the dropouts, not speed.

@rbanks88 Are you sure you’re reading things right? I don’t think your 40GB plan can possibly mean a transfer speed of 40 Gigabytes per second; that’s way in excess of what’s possible, let alone available, using consumer networking technology (see eg here. I strongly suggest the 40GB refers to a maximum monthly traffic limit, which is why 200GB is being proposed as an upgrade.

So two things: first, does your broadband contract with Centurylink make any promises about a minimum speed (in Mbs, megabits per second)? I don’t know about America, but very few UK ISPs make hard contractual commitments of that nature, the best you’re likely to get is a “reasonable endeavours” clause.

Second, a typical ISP response to breaching monthly capacity limits (ie the 40GB) is not to cut you off completely, but to dramatically throttle the (usually download) speed of your connection. One way that can be done is to deprioritise packets that are addressed to you. That might account for the behaviour you have been experiencing, you’d see apparently random reductions in speed that are in fact related to how much traffic other people are sending/ receiving at the time.

1 Like

In a post a couple of days I corrected this:
“And my mistake on our internet plan. It’s 40Mbps, not 40GB. The amount is unlimited.”

It’s the dropouts, not speed. I get zero Mbps for 30 sec. (enough to break downloads and some web page activities) OR 37-38 Mbps.

I’ve been told I should try to connect a laptop directly the ONT on the side of the house. I tried it a month or two ago and couldn’t connect. I’ve recently realized that might require the PPPoE login like the router uses to connect, so Centurylink doesn’t have people getting free service by just plugging into the ONT. If a PPPoE login is required, how would the Mac handle that when directly connected to the endpoint?

To connect directly, you would need to create a new network service (using System Preferences / Network) of type “PPoE”.

Thanks for the quick response. I found this article that steps you through the process:

https://support.zen.co.uk/kb/Knowledgebase/Fibre-Broadband-Creating-a-PPPoE-connection-on-Mac-OS-X

I’m still not able to connect directly to the ONT via PPPoE after setting up the network service with my ISP’s assigned username and password. (same ones my router uses). There’s a field for PPPoE Service Name, but Centurylink support says there’s nothing required. Do I need to change any defaults behind the service’s “Advanced” button? (TCP/IP, DNS, WINS, Proxies or PPP)

Thanks,
Russell

Are you restarting the computer immediately before connecting to the ONT? I would also turn off WiFi before that restart. You want the Mac to grab the ONT as it searches for a network, and a restart with no network connections is a simple way to do that.