One of 3 monitors is now "emulated" and not working correctly on Mac mini 2018

I have 3 monitors connected to my Mac mini.

  1. LG 4K landscape (primary and center) by USB-C
  2. LG 4K portrait (extended and left) by USB-C
  3. Acer FHD portrait (extended and right) by HDMI
    Before Mac 12.3, all three worked at native resolutions just fine
    With Mac 12.3 the Acer would not show anything on screen, but it would show in Display Preferences as an Emulated Disp Display.
    Now with Mac 12.3.1, all three work again, but now the Acer is still showing in Display Preferences as an Emulated display, but it does show an extended desktop, just in a strange resolution when used as “Native”, which is 1024x1280.
    Looking in About This Mac shows the Acer as though it’s emulating a 17" Apple display.

Any ideas on why this is showing as emulated? I can’t seem to find any way to resolve this. Shown below are my preferences and about. Any guesses as to why this is happening or how to resolve it?

Have you got the most recent macOS patch? I think I saw something about this in the update notes.

Edit: I see I misread your post. Apologies.


Have you checked to see if there’s any Acer updates needed? Years ago I had to download and run an updater program for my LG monitor. (I thought this was especially weird as the LG monitor was the 4K Ultrafine designed and sold by Apple.)

No problem. What was strange is that it went from an emulated screen that didn’t show anything to a screen that does show something. I heard a few other people say that 12.3.1 fixed some display issues, which was why I even tried it again.

I just checked the Acer site and they have nothing for Mac OS. Everything about updates and drivers was all about Windows. It is an odd thing. Beyond that, I’m sort of surprised that Apple’s own KB doesn’t seem to say anything about emulation displays.

Things to wonder about and try.

  • Is that color profile “K243Y” right? Try a more generic profile?
  • Clean shutdown, not restart (may take two shutdowns!)
  • Unplug everything.
  • Does it work okay if that Acer “emulated” display is the only one connected? Check cables and ports and be careful when reassembling.
  • If it does, sleep the Mac and add a USB display. Wake and check for function.
  • Repeat with the last USB display.

Do scaled resolutions work on the emulated display?
If nothing works try a DisplayLink adapter. Did wonders for me connecting three 4K displays to an M1 Mini
Have you connected HDMI direct to the Mini or via a dock?
Change Color Profile to RGB