Opening .ics files in Fantastical by default

My default calendar app is Fantastical, and it is set as such in the preferences of the Calendar app. However, if I open an .ics file, the native Calendar app opens to add it.

This is new behavior – ics files used to open in Fantastical. I tried going to the “get info” page for an ics file and setting it to open with Fantastical instead of CalendarFileHandler,app. I figured if that worked I would make I the default behavior. That gave me an error:
image

Right clicking on the ics file and opening with Fantastical does work, but I’d like this to happen automatically. Any advice? (I’m running the current version of Monterey on a 2020 MBP)

thanks!

1 Like

Have you tried right click > get info > open with > choose Fantastical from drop down > change all ?

3 Likes

:point_up: this is the way.

(20 characters)

I had one random .ics give that error last week. Unfortunately I can’t locate it now to compare the source. Are they all doing that for you?

The OP said she did that. See her second paragraph.

Yes! This is what gave me the error! :disappointed:

Are you having the “unidentified developer” error with all .ics files? For example, drag an event out of Fantastical to the desktop, to create an .ics file, and see if that new file throws the error?

I am having the unidentified developer error with all .ics files, yes. and yes! If I drag an event from Fantastical to my desktop to create an .ics file, I still get the same error!

Strangely, it seems macOS knows that .ics files belong to Fantastical, and macOS does not trust Fanastical.

I wonder if the code signature in the Fantastical.app package somehow got corrupted. If this were my problem, I would completely uninstall Fantastical and start over.

See “I’m having trouble opening Fantastical. How do I reset Fantastical and start over?” and follow their advice.

1 Like

so the more I think about this, the more I think the bug is with CalendarFileHandler.app

I downloaded BusyCal, set it as my default calendar application, and repeated everything I’ve tried above. Everything works (or doesn’t) exactly the same way!

So now my current theory is that the file handler is not routing the ics files to the correct application. Going to head over the the apple support forums and see if I have any luck there. (would love to just replace that app and try again!)

If that is the case, then there is some possibility that your installation of macOS is corrupted. I wouldn’t bother with the Apple forums – I’ve found that questions there are increasingly handled by weird bots that reply with unhelpful responses. Maybe try an appointment with Apple Support directly?

1 Like

Apparently had just figured out how to fix this.

  1. Open with right click your calendar event.
  2. Hold option modifier(⌥)
  3. Choose the calendar of your preference

Or - to do it for all .ics files:

  1. Open file inspector
  2. Look for “open with” section
    Screenshot 2022-04-26 at 10.47.58

Just for searching/posterity’s sake: these steps don’t fix the issue (if you have the issue). These steps are what show you that the issue exists (on some machines). The OP’s posts show that her knowledge of how to set the default app is not the issue. OSX’s issue of how that setting works (or doesn’t) is the problem for some installs. Most people do not have this issue including, it seems, petka, for whom these steps work.

1 Like