Orbi and Homekit? (aqara issue)

I set up an Aqara motion sensor and an M2 hub. Via the Aqara app, the responsiveness is rock solid no issues.

But I set up a Shortcut automation to turn a light blue when the sensor triggers (within a 2 hour window). That automation works fine the first day and then does not work again the next day until I reboot my home router. I have tried rebooting the M2 Aqara hub and other devices. No luck.

in reading online, I have seen a number of people complain about HomeKit and Orbi routers, particularly the older model I have, the RBK50. I have noticed a lot of little HomeKit issues through the years, and wondering if it’s related.

has anyone had any issues with Orbi and HomeKit? I would hate to spend all the $$$ to upgrade to an Eero, but if I’m going to do it, I should do it now, during the Black Friday sales!

I replaced my Airport network with Orbi in 2018. I am fully on HomeKit. I have a long L shaped home with one router and two satellites. Almost everything has worked fine with the exception of a few devices on bluetooth LTE. Not an Orbi problem since it does not deal with that format.
Whenever I get involved in Wifi router conversations, it seems a lot more are using Eero than Orbi. I have found Orbi to be rock solid.

1 Like

Also an Orbi owner. Mine is an RBR50 (v2) with one matching satellite. I get some HomeKit problems but nothing consistent like that. It’ll just be some devices won’t report the correct status to the Home app, or… of course… Siri being an idiot.

Me: Hey Siri, turn on the lights
Siri: (2-3 seconds later) Working on that

That’s almost 100% of the time lately with Siri, but my automations via Stream Deck → BetterTouchTool → HomeControl → HomeKit is very reliable. You’d think the house of cards with the Stream Deck would be less reliable than a pure, out-of-the-box Apple solution, but no.

I’m no networking expert but this doesn’t seem like a router issue. I have the RBK752 with x1 satellite and they have worked flawlessly. With this latest update my iPhone/iPad are slow to open the Home app and still can not get the routines to run. Testing the Hue and Aqara functions via their apps everything works which leads me to believe HomeKit is the culprit.

Right this minute actually, I am pulling the power from all the AppleTvs and other stuff to see if I can trace down the source device with issues. :roll_eyes:

thanks for the replies!

I ordered an Eero Pro 6E from Amazon because of their Black Friday sale. as much as I would love it to solve the problem, based on these comments, I doubt it will. (I would love to return it and save $400.)

I was also thinking of upgrading my older Apple TV to the new 4K with Thread support. (I recently turned off HomeKit on my older Apple TV, hoping to kick control over to one of our HomePod Minis, but that did not fix the problem.

what is strange is that if this was a more global issue with HomeKit, you would think it would be the number one thread on this and every other message board, haha!!!

I’ll report back after I try swapping out the orbi for the Eero. thanks!

as predicted, the new Eero router did not solve my HomeKit issue. neither did upgrading to the new Apple TV 4K with Thread support. Real bummer.

Of course now that I have the EERO with the faster speeds, I don’t think that’s getting returned. :innocent:

Not sure about the Apple TV. It doesn’t do anything my 4-year old model doesn’t do, but it feels like HomeKit devices are more responsive when triggered by Siri and by shortcuts. might be psychosomatic. Not sure how to test it scientifically, but we’ll give it a few days.