Overcast Won’t Download New Episodes

Hi all,

Has anyone noticed Overcast having trouble downloading new episodes? Everything worked fine until I upgraded to the 11 Pro. I was running the beta on the previous phone and had difficulty updating the new phone to the beta so I could restore from iCloud backup.

Last night I did a hard reset because the phone wouldn’t even update to 13.1.2, wouldn’t download the native Podcasts app, not the new episodes. It updated iOS, then all the episodes fell into place. Upon my evening commute, no new episodes.

I’m on WiFi at work and at home and have nothing blocked on either networks.

Anyone have any ideas? So far, this phone has been nothing but trouble.

Interesting, I just got my 11 Pro and no issues. I have had an issue with Overcast in the past where an episode was showing as available but would not play. In those instances I’ve fixed it by deleting the “corrupt” episode and going to the show to download again. That might get things rolling again.