OWC Thunderbolt 4 Dock - ethernet issues

Hi All - I recently got one of the new OWC Thunderbolt 4 docks, which is connected to my 2019 16" MBP. When I plug my ethernet into the dock, my wifi router suddenly stops working.

My home internet starts with my Verizon modem. From the modem, I have two ethernet cables coming out. One ethernet goes straight to my office (and eventually into the OWC dock), the other goes to our wifi router running in AP mode (so it gets its IP address from the modem). Before getting the dock, I could plug the ethernet into a USB-C to ethernet dongle and directly into the MBP and it worked fine with no impact on my wifi.

But when I instead plug the ethernet into the OWC dock, the wifi router suddenly has errors and everything connected via wifi is unable to access the internet.

I don’t fully understand all the nuances of networking, but I’m guessing that there’s something going on with the dock that is blocking the modem from giving an IP address to the wifi router. But it doesn’t seem to be the dock on its own. Because when the dock is powered and the ethernet is connected but the dock is not plugged into my MBP, the wifi still works correctly. It’s only when the ethernet is connected to the dock and the dock is connected to my MBP, that the wifi router becomes unable to access the internet.

Any advice or thoughts would be greatly appreciated

When the WiFi stops working, can your Laptop access the internet? Can you ping or connect to the WiFi router (e.g. access the Administration function)?

Perhaps have you given your OWC Ethernet the same
IP address as the WiFi router running in bridge mode?

1 Like

It sounds like we need some more information to help troubleshoot.

As others have suggested, I would propose that you connect your laptop to WiFI, log in to the admin interface on your WiFi router, and see what its IP address is. As an access point I would expect that it has two different IP addresses, one for its connection to to your Verizon modem and one for the internal WiFI network.Also check to see what IP address your laptop has been assigned. I would then connect the laptop to ethernet via the OWC dock and see a) what IP address has it gotten, b) in the Network preference pane, is it connecting over ethernet or WiFi, and c) can you still connect to the WiFi router’s configuration page.

There are a lot of things that could be going wrong here, but was it odd is the fact that you can connect the laptop via USB-C to ethernet and have things work but not if you use the OWC doc, which I would think excludes many of the problems that often arise in this kind of setup (like the WiFI router having DHCP enabled and giving out IP addresses on a different subnet than the Verizon router is using, causing you to have two different subnets for WiFi and wired, and hence devices connected wired cannot see the WiFi network and vice versa).

If you report back on findings, hopefully one of us can help you troubleshoot further.

Have there been any postings online about similar issues from others?

I’m a little confused here, where is your DHCP server?

Thanks, all. Networking is not my strong suit, so I’ll do the best to try to answer the questions, but I may not be understanding everything.

My Verizon modem/router says it has IPv4 connection type DHCP, with an IPv4 address that starts 173.xx.xxx.xxx. When my MBP is connected to Verizon modem/router by ethernet, it has an IP address starts with 192.xxx.x.xxx. Also, my wifi access point also has an IP address 192.xxx.x.yyy. The only difference is between the ip addresses is the last 3 digits. Also, from the Verizon modem control panel, it can see all of the devices connected to the wifi access point, and all of them also have 192.xxx.x.zzz ip addresses, with the last 3 digits being different for all of them. So to sum up, everything on my network, whether connected directly to the Verizon modem or to the wifi access point, is getting a 192.xxx.x.xxx ip address.

When I connect the ethernet to the dock, the laptop (with wifi off) still gets a 192.xxx.x.xxx ip address. After a few minutes, the wifi goes down, and the access point stops broadcasting. So, I cannot connect to it via wifi any longer. If you need more information, I could try to plug in directly to the wifi access point over ethernet when it goes down to collect additional information (if you tell me what I should look for).

I have not seen any other reports online about this issue yet (although this dock is fairly new).

I don’t know if this answers all your questions – let me know if there’s more data I can provide.

Have you tried calling Mac Sales Support? They are pretty good. I bought some ram from them and couldn’t figure out how to get it in. I went over there (I lived in Crystal Lake) and a support tech came out and showed me the trick. I’ve also had good luck with their phone support.

Apologize in advance, but to help level set. Respect the masking of
ip addresses but I wish I had a nickel for every time I mixed them up.
There is no need to mask the 192 addresses as they are non-routable
and I, as the evil hacker, would need to know your WAN address, which
you have (correctly) obfuscated.

Let’s then exaggerate the private ip addressing. We will use
192.168.55.x The 192.168.55 is your Network address. The .x
is your host address and you will have 253 to pick from

Verizon modem/router

Set the LAN address to
(Leave WAN as DHCP as this is set by your ISP)

Set VZ modem/router DHCP Server ON and range -
(This will give you 50 local addresses, need more? adjust accordingly. Additionally
this will allow you to note that any 3 digit ip address might be an issue)

Wireless Router

Set the LAN address to

Set the DHCP Server OFF

If you need to set a gateway?, use the VZ address -

(It’s good practice to set any static address outside of your DHCP range.
You have a printer?, a NAS?, a xxx? whatever
Just don’t go into your DHCP range)

As you have been working this for a while, I would reset the network stack
on your Mac. This is (mildly) different per OS version, and is easily Googled
for your specific use case.

Then I would reboot everything, and if this doesn’t go, then the suggestion
from @Mark is a good one, ASSUMING these are the only devices that are
in your network path. If there are other devices, then the specific model
numbers would help, as there might be some additional parameters that
are impacting your network.

Your network appears to be operating correctly. 192.168.0 and 192.168.1 are typical IP network numbers for consumer routers (I was confused because you initially called the Verizon device a “modem”; it is actually a modem and a router, as you have stated above; sometimes this device is called a “gateway”).

Using the gateway’s administrative interface, you have enumerated the active addresses before plugging into the dock. Can you do the same after plugging into the dock?

I’ve seen this problem as well, with the OWC dock and an AT&T router.

SO, how did you make out @ryanb??

Here is a post on reddit about this, saying it’s due to the realtek ethernet chipset in it lacking driver on big sur.

Apologies for the very late reply. To be honest, I was partly intimidated by the prospect of monkeying with settings that I don’t fully understand. But more significantly, in the course of all of this conversation and my own research, I realized part of my issue was that I was significantly complicating my own set up by having the Verizon gateway feed both my Wi-Fi and my wireless routers, when in fact I didn’t need the Verizon gateway at all.

Last week I got a new mesh networking system. I removed the Verizon gateway and ran Ethernet from my fiber ONT directly to one of the wireless AP’s and set it up as a gateway. I then ran the Ethernet from the gateway to a unmanaged Ethernet switch, and connected my home’s Ethernet lines to the switch.

Now instead of having two systems (the Verizon gateway managing the Ethernet connections and the wireless AP managing the Wi-Fi network) I have one system managing everything. I’m sure the DHCP range suggestion would have worked, but I think this new setup is hopefully simpler and easier for me to manage.

The OWC dock now works without crashing my whole network. Maybe there was a software update to MacOS in the past few months that fixed the Realtek driver as @SuperTachyon suggested, or maybe it was my simpler set up. But either way, it’s now working.

A very belated thank you to everyone, especially @csf111 for the detailed and helpful feedback.


The ethernet in my OWC TB4 dock worked fine with my M1 Air, but I just got a 14" MBP and it doesn’t even show up in the Network section of System Preferences, which tells me the OS isn’t even seeing the device.

I know the dock otherwise works because I can see my iPhone plugged into it from my computer, and my UltraFine 5k is plugged into it too as I type this.