Permissions Problem

Hi MPU Fam,

So this morning I restarted my MacBook Pro (13-inch, 2017, 2 TBT3) as a few programs were hanging for inordinant amounts of time. After restarting the computer, I ran into a couple glitches.

First, as it was restarting and all my start up apps were getting running, Bartender (which I’ve been using for years and currently have through my SetApp subscription) asked for permissions through settings. Specifically, it wanted access to Disability Access and Screen Recording.

No worries. I click the + sign to add it, it opens my application folder, I select Bartender, and hit open to add it, and nothing happens. It doesn’t add the app. This happened with both of the desired settings.

I was frustrated, but thought I’d do a quick ScreenFlow so I could seek help and show what was going on. Well, that didn’t work. When I opened ScreenFlow, which I just used two days ago, it said it needed access to my permissions. So I did the same thing, initially thinking it had something to do with SetApp. But as you can see on the video, it did the same thing. I select it, but it doesn’t save my addition.

Am I doing something wrong here?

Here’s a link to what was happening - sorry that it’s shaky, I recorded it on my iPhone… https://imgur.com/a/6aNrsiT

Ok, before nuking apps, I restarted again and it seems to have resolved itself and gone back to regular/normal permissions. I still have no idea what was going on, but it works now. :slight_smile:

2 Likes

This has been happening to me, too, since I upgraded to Ventura about 10 days ago. It’s happened with Bartender and with Default Folder X. It seems that restarting solves the problem - until it happens again. I updated to Ventura 13.2 this morning, but, unfortunately, the problem hasn’t gone away.

1 Like

probably not directly related to the issue you guys mentioned here. However, I found it extremely confusing and frustrating that sometimes add new apps require one time approval at the Security and Privavy screen. From experience, if I missed that I do not get a second chance to approve.

Worst that with the new Ventura Settings , I do not even know whether to find it. Most instructions from app devolpers still refer to the old "preference settings for Security and full disk access, etc

1 Like

same experience here. that is, on a restart, all kinds of apps re-request permissions, and panes in the security process/privacy Settings initially show as blank until i restart again. happens to me about once a week

1 Like

just sharing another experience. After playing ping pong games between Google and Apple (and I escalated the issue to both companies), Apple support finally find it was the Mac OS that stopped me from connecting my Mac to Pixel 7 Pro to do direct file transfer. However, I need to re-install Mac OS again, which I am not keen to do while I am away from home. It has to wait till I go home.

It was not easy to get Apple Support to admit that the issue is at their end for 3rd party app. It also shows that getting the required permissons to 3rd party apps is not always a 100% sure bid. In this particular case, the support was good enough to prove that the Google App Andriod File Transfer works in Safe mode but not in normal mode. Otherwise the ping pong game will go on a lot longer

1 Like

Since Ventura, almost every time I boot, an app (typical candidates: Keyboard Maestro, Default Folder X and LanguageTool) asks for permissions, but they are usually already there. Briefly switching the permission off and on satisfies the app in question. Bartender and Better Touch Tool also used to be there, but they seem to have done something about it through updates. If a lot of apps ask when booting, in my experience the best thing is to boot again immediately, which then almost always works without asking again.

I think the whole thing has happened in isolated cases since Big Sur, but it has definitely gotten worse in Ventura.

3 Likes

This happens to me on my Mac Studio running Monterey. Every time I boot Karabiner asks for permissions. I ignore it as permissions have been previously granted and Karabiner works just fine. My guess is that this is a race condition.

I had a different issue with my 2018 Mac mini, also on Monterey then, which often kernel panicked on shutdown. I suspect, but never proved, it was caused by an attached device (I still have the mini, it is now running Ventura, and I no longer have this issue; and as most of the devices are now attached to the Studio it is further confirmation of the cause). The issue was that pretty much everything would ask for permissions on startup and would need to have them granted.

1 Like

Yes, settings initially show as blank for me, too (until I restart).

1 Like

I’ve had the same issue with both Monterey and Ventura. Almost every time I had to reboot twice, as the first time a whole heap of apps request permissions. I resorted to preventing as many as possible from loading on start, and created a Workspaces workspace containing all of those apps so I can launch them in batch once Ventura has fully booted up (you could use Bunch or Keyboard Maestro just as easily). I suspect the issue is with apps loading before MacOS has fully booted, potentially not having loaded up its permissions database yet? By delaying their start it seems to resolve the problem (mostly :wink: - YMMV).

2 Likes

I’m on Ventura, and get this problem almost every time I reboot. I do the toggle on/off/on dance, or reboot, and it goes away.

1 Like

I’ve been having this as well. Ventura, M1 Air. Rectangle causes it most frequently. It’s a real time suck having to enable permissions again (settings isn’t the fastest app in the world), or reboot.

1 Like

I originally skipped this thread because it didn’t seem to apply to me: how wrong I was!

After migrating to a new M2 MacBook Pro yesterday everything went well and every app was given its requisite permissions. Just before sleeping I happened to reboot…and was confronted with a screen full of apps requesting permissions that had already been granted. What was worse were the blank permissions panes already referred to. I had no clue what to do or what had gone wrong.

After failing to sleep, in the middle of the night I got up, rebooted the MacBook Pro again…and everything was back to normal. Since then there has been no problem but I really could do without those sorts of frights.

Stephen

5 Likes

You are preaching to the choir. This has become a regular part of my life since upgrading to Ventura. An added bonus is that sometimes I can’t restart the computer to reset the permissions problem because of the screens asking for permissions. Fantastic.

3 Likes

I’m “glad” to see that I’m not the only one with this problem… Here exact the same as you guys are experiencing. :confounded:

4 Likes