Please help me figure out what's interfering with my scanner

I posted an earlier version of this on the Apple Support forums but have not had much in the way of response. I figure there are a lot of smart people here, so here goes.

On November 27th I disassembled my desk setup, including my Epson Perfection V370 Photo scanner, and assembled my brand new desk. Since putting everything back I cannot reliably scan anything using VueScan or Epson Scan 2. Whichever I use, I can never get more than a handful of scans done before either the scan gets stuck at the calibration stage or the software crashes.

I feel like I have tried everything. I have:

  • tried different USB cables
  • tried different USB ports in different hubs and directly on the M1 MacBook Pro
  • turned off various equipment including USB hubs
  • updated/reinstalled software and drivers
  • downloaded and run an ‘El Capitan patch’ Epson put out some years ago for similar problems
  • bought a new Epson Perfection V600 Photo scanner and repeated all of the above
  • moved the scanner to different locations on the desk

Once I got the V600 I’ve not gone back and tested the V370 again.

I thought that patch had sorted it because I managed to scan three frames of film without it failing (previously I had never managed more than one), but the very next attempt hung on calibrating the first frame.

Note that prior to replacing my desk I probably had not done any scanning for a month or two, but up to that time the V370 had worked FLAWLESSLY for more than a year. I did have similar sorts of problems some years ago but do not remember how they were resolved. It may have been a noisy USB hub, but I had tested the V370 and V600 with exactly the same equipment powered up that saw the V370 working perfectly and still the problem persists.

Here’s the thing, though. I did a session with Apple’s Image Capture app a week or so ago and managed to scan a dozen documents no problem. Today I did over two dozen document scans with Image Capture. Also no problems.

Image Capture uses the “ICA Driver” (I figured out ICA = Image Capture App) which I installed from Epson’s site. I recall when I first got my M1 MacBook Pro in November 2020 I had problems with the (V370) scanner not being recognised and discovered I needed to install both the ICA Driver and the Epson Scan 2 software (which is described on the Epson site as “Scanner Scan 2 Driver”.

VueScan says I need the ICA driver, which implies that’s what it uses:

But VueScan repeatedly hangs and when I contacted their support, I got a bunch of things to try (all tried) and then “Well it works for a lot of other people with the same scanner model”. And I believe them.

So where I am at now is this: I figure there has to be something that is interfering with the scanning process, possibly at the USB level. The earlier problem, for which I think that patch applied, (and as I recall it) was related to the scanner sending events to the computer and the software was missing them. The patch sought to ensure the messages were not missed. Somehow.

I tried even booting in Safe Mode one time and using Epson Scan 2 and still encountered the problems, so if it is something interfering, it must be something pretty low level.

Tonight I thought I’d open Activity Monitor and see what jumped out at me to try killing off, but there are 595 processes running and I just feel overwhelmed by the thought of randomly trying stuff, particularly because it’s not quick to see it fail, and I have been led to believe it was working before, only to be let down many minutes of scanning later.

So, hive mind of MPU, your suggestions please:

  • What types of process should I be looking at?
  • What other things might make a difference that I haven’t tired?

I emailed Epson support and after the “try plugging it directly into the computer” response I went back with a detailed rundown of most of the above and got a reply saying “call this number”. I don’t hold much hope that will help.

I haven’t done much scanning, but maybe I can help you think through some troubleshooting steps.

  • Sounds like the hardware is good.
  • I think something software-wise changed in the couple of months you didn’t scan. Maybe an OS update, update to one of the apps associated with scanning, etc.
  • The El Capitan patch jumps out at me.
  • Confirming the hardware is good, USB drivers are good, etc.

I assume Apple Image Capture lacks features that you need?

It sounds like there is some sort of conflict between the various scanning apps and /or patches you have installed. Perhaps they try to monitor for scanner activity, and are tripping over each other.

At this point I would

  • do a backup
  • make sure the backup is good by restoring files or using the backup utility’s validate function.
  • try to cleanly remove the scanner apps using CleanMyMac X or similar
  • Confirm things are working by using Apple Image Capture.
  • pick the one scanning app you want to use and install it.
  • Be deliberate about following their instructions closely.
  • I wouldn’t use the El Cap patch in any case, unless the vendor tells you (you personally) to do so.

If that doesn’t work, a reinstall of macOS may be in order. Do a backup. Remove the scanner app(s), reinstall macOS. Confirm things are working by using Apple Image Capture. Install a single scanner app. Again, being deliberate about which app you want to use, and following its instructions closely.

Finally, if all that doesn’t work, a nuke and pave may be in order. Do a backup, be sure it’s good. Format the drive and install macOS. Install any OS updates. Confirm things are working by using Apple Image Capture. Install a single scanner app. Again, being deliberate about which app you want to use, and following its instructions closely.


Ack! Sorry you’re dealing with this.

Is it correct to say both Epsons do work correctly, but don’t work correctly with Vuescan? Is there another app that they don’t work correctly with? Did Vuescan update in that period that you didn’t scan for a couple months?

1 Like

Correct. It does a good job of simple document scans, but transparencies — most of what I have a scanner for — is a real chore.

Ah! I had considered removing software, including drivers, but thought that might be a hard road. However, I do have CleanMyMacX.

Thanks, I hadn’t considered this intermediate step.

This I had considered. I do have some other weird goings on lately which may benefit. Like QuickLook refusing to display previews unless I restart Finder and Safari becoming unresponsive.

That would be a correct statement. They also do not work correctly with Epson’s own Epson Scan 2, falling at the same hurdles. I did try downgrading VueScan to an earlier version but it made no difference. My gut feel is that a macOS update may be the culprit. Obviously (I hope) Apple would know to make sure Image Capture works with any changes in the relevant OS areas, but vendors may be caught out. I’m pretty sure that’s what happened in El Capitan.

Well the re-install of apps and of macOS didn’t do the job. I do wonder what the macOS reinstall does actually do because after it started up, everything was back the way I left it. Wallpapers, auto-start apps and their configs. Given macOS itself is on a signed, sealed, read-only volume I can’t see how that’s going to get out of whack.

Next step I am trying is simply to re-install the two drivers (and not the patch) in the vain hope that will magically work, then I guess next steps are:

  • ring Epson, sigh.
  • Nuke and pave, bigger sigh