Possible to force mesh wifi to set up 2.4gHz channel?

Not sure others have this experience. I have the Asus Zen Wifi AX mesh wifi network. I have a lot of difficulties setting up devices that claim to work only with 2.4gHz channel. I believe this issue is not unique to Asus but mech wifi in general, including Google Wifi or Amazon eero.

Just wondering whether it is technically feasible to force the configuration to set up a separate and dedicated 2.4gHz channel for these IOT devices. Or are these other solution to this issue?

I just turn off 5 GHz while setting up if there is a problem, then re-enable it once done.
It seems to be fine doing this.
(I use TP-Link, not Asus)

1 Like

Not sure about your device, but for the Eero, if you dig into the settings (Troubleshooting > My device won’t connect > My device is 2.4 GHz only), there is an option to temporarily pause 5 GHz so you can configure devices that require 2.4 GHz for setup. Perhaps yours has something similar?


thanks @GraemeS and @Evan , I shall check that out

1 Like

Some brands let you turn it off, others not. My Orbi does not, but it does let me set the transmit power. I got one device sorted by turning 5GHz transmit to 25% (only options were 25,50,75,100) and then taking the device to the opposite end of the house from the router. At that point my phone and it would connect to the stronger 2.4GHz signal.

1 Like


This is a huge help when setting up IoT devices.

1 Like

That did the trick for me a while ago. Sometimes have to repeat switching off 5Ghz for 2.4 devices to reconnect.

In the end I solved it by keeping my guest network 2.4 Ghz only and connect all IoT to the guest network.

I have since moved on from mesh and wired all access point, which take all the backchannel communication away and made wife much more stable

1 Like

this is not a bad idea, may try that