Possibly bricked my MacBook pro


Let’s start from the beginning… I was trying to erase to factory settings my MacBook Pro from late 2016 (i believe). I looked online how to do it. I don’t remember 100% what I did earlier but I think what I did was go to disk utility then erase Macintosh HD and then restarted the macbook. It did erase everything but when I booted it back up it gives me the little flashing folder with a question mark and tells me to go to If your Mac doesn't start up all the way - Apple Support.

So basically I think i accidentally deleted my operating system or something. When I put it in recovery mode and do first aid at first it kept saying Macintosh HD was corrupted but wouldn’t fix itself because it told me to boot up and put in recovery mode… assuming my Mac even works. Now first aid says everything is fine after some fiddling. However when I go to install macOS (it tries to install sierra even though it was on Monterey before wiping) it says there was an error and try again. I’ve tried so many times and it still doesn’t work.

Is there anything else I can do? Should I take it to a repair place? Have i bricked my MacBook?


You can probably revive it with a usb stick with macOS on it. You may have done something to hose the recovery software on the Mac, but you can get what you need via usb. A google search and usb drive or trip to the Apple Store should get you up and running again!

I’m in a similar situation with an older MBP. If I recall correctly, the problem goes somethig like this:

  1. You have an older Mac that originally shipped with some older version of the OS. You upgrade it to a newer version (I don’t recall which one) and the SSD is reformatted/repartitioned in such a way that the old versions of the OS can’t deal with it. I’m not sure if this is completely just that it gets converted to APFS, or if there’s shomething else that happens.

  2. Something goes wrong to the point where you have to do an Internet recovery. In this case, I believe it boots to the version of the OS that it first came with, regardless of what it was running before things went wrong.

  3. The old OS can’t deal with the new SSD state and throws an error, leaving you in a weird place. I don’t think that the old version of Disk Utility can even reformat the SSD at that point. (Memory is hazy on this)

I think Jezmund’s solution is the only one that will work.

The fact that you can get into recovery mode tells me the machine is probably fine. How did you format the disc?

If you can get into recovery mode you can probably reformat your drives and do a clean install.

If that does not work try the Option + Shift + Command + R internet recovery option. That would reinstall the OS that originally came with the machine and you can upgrade from there


I think that’s that the OP is trying and may lead to the problem loop that I described. I have this going on myself on an older MBP, but it’s old enough that I can’t be bothered to try to fix it.