Prevent MacBook Pro re-opening Apps after shut down?

Since upgrading my MacBook Pro (Mid 2015) to macOS Catalina (10.15.1) it re-opens Apps after a shut down. This did not happen on Mojave.

What setting or default do I need to change to prevent this?

This is the default behavior for Mac. How are you shutting down? Are your running command through a launcher or you just run the command from the System menu?
Choosing Shutdown from System Menu, the dialog that appears has a checkbox to reopen apps, you can uncheck it.

1 Like

The shut down/restart modal pop-up has a checkbox for this.

I use the system menu and I uncheck the checkbox.

All previously open apps? Or a single set of apps, always the same ones?

I’m not sure about the pattern yet (and I usually even close all Apps manually before shutting down).

OK - asking in car there are apps that have preferences to start up automatically when the system starts, such as Skype, Onedrive and others.

Places to look to see:

System Preferences/Users and Groups/Your user - Login Items tab

/Library/LaunchAgents (these are usually background items, like application preferences, rather than actual applications. To get to the Library, open a Finder window, hold the Option key and click the Go button - you’ll see Library in the list.

I think this is unlikely, but it might help to narrow down

2 Likes

It sounds like apps are auto starting on login. You can change this in System Preferences > Users & Groups > Login Items. You have to remove items from here to prevent them auto starting - unticking them shows them when they launch instead of hiding them.

I though about that as well, but two of the Apps that automatically started this morning (1Password main App and Sublime Text) are not in those Login Items.

I think you have to go into 1Password preferences to stop it from doing this.

“KnockKnock” by Objective-See will help:

See what’s persistently installed on your Mac. KnockKnock uncovers persistently installed software in order to generically reveal malware.

So it’s designed to look for malware, but it’s also really good at seeing all of the different things that are set to launch at login.

It’s a free app. And Objective-See is a respectable/trustworthy company.

2 Likes

I hope I’m not getting annoying by replying “already did that” all the time, but I do run KnockKnock from time to time.

Both the 1Password main App and Sublime Text are not in there.

Also, the erratic behaviour is pretty inconsistent; I have not discovered a pattern yet.

FYI KnockKnock 2.1.0 just was released a few minutes ago.

1 Like

Not annoying at all, but it’s not a very well-known app, so it’s not something I would assume people would know about.

(As bowline mentioned, there is a new version just released.)

Given everything you’ve tried, it almost sounds like there’s a corrupt file somewhere. I’m wondering if it thinks that it is supposed to be relaunching apps even if you’ve said not to.

Here’s what I would try:

  1. Quit all the apps manually so there’s just the Finder running
  2. Go to  » Log Out…
  3. When the confirmation pane pops up, DO check the box for “reopen windows when logging in”
  4. Log out
  5. Reboot
  6. Log in and see what opens

Hopefully nothing opens. BUT, if you still see apps launching, then you know it’s not the “reopen windows when logging in” that’s responsible.

However, if apps do still launch, then I’m at a loss to guess what is causing it. At that point I think I’d probably start reinstalling apps that are launching at start to force a re-write of their preferences files, but that’s a shot in the dark.

There might be something in a cache that isn’t being cleared properly. You could try deleting everything in ~/Library/Caches (back up first!) or, for a more detailed approach used a utility like Onyx (free).

I’m not sure that that’s the issue, but there’s clearly something hanging around in your system that shouldn’t be