Printing PDF files on 12.0.1

I know printers are mysterious and unknowable, but perhaps there is a wizard with magical powers in this forum…

I have a B&W HP LaserJet, which is going strong into its second decade. Never had a bad day with it. I have updated to macOS 12.0.1 a few days ago. Everything was going swimmingly until today, when I needed to print out a PDF file. I usually use Preview for these tasks (and have had no problems up to and including Big Sur), but on Monterey, I got an error: a single-page printout, which says,

ERROR: undefined
OFFENDING COMMAND: (every time I try to print, something different comes up)


Same thing happened when I tried PDF Expert. Thankfully, it worked with Acrobat Pro DC, but the fact that I can’t use Preview is very disconcerting. (I tried printing some other file types, and they seem to do OK.)

Any thoughts?

Don’t have a fix, but if it helps you aren’t the only one.

From what I can piece together, this is a problem with Apple’s PDFkit. From the error text you have, and the fact that it says STACK, that looks like a PostScript error. PDFkit apparently converts the PDF to PostScript for printing (PostScript is more or less a language for printers, so if you want to talk to a PostScript printer, you have to speak that language).

Hopefully a fix will be coming soon.

1 Like