Problem Importing JPEGS into Apple Photos


I’ve retrieved a heck of a lot of jpgs from my late fathers three old PC’s running Vista/XP. He hadn’t used these for a few years but they were running fine when I switched them on. The photos were scattered all over the place and so I wanted to sort through them and possibly make them available to family to view before I started deleting and marking ones to keep.

I thought I would create a new library in Photos to house these as I want to keep them away from my own.

My problem arises when I try and import them. I have for example started with a folder of 6000 jpgs and dropped them into Photos. Only about 3,000 successfully imported with the other 3,000 bringing up an error (example below):

Now, I have tried the following in order to try and fix this:

Run Disk Utility on the drive from within MacOS.
Run Disk Utility on the drive from the Restore Menu after a clean boot.
I have reset the permissions of individual files and of the containing folders.
I have moved the photos to an external USB drive and tried to import from there.
I have moved the files to a different Mac and tried to import from there.

Running latest Mojave on both Macs.

I can view the jpgs in preview and other apps and they appear fine, i.e. the jpg’s do not appear to be ‘broken’.

Any ideas?

Did you reset the permissions in the Info window or in Terminal? If you didn’t use Terminal, the following should work.

  1. Make a backup of all your photos (Do this on a copy of the images)*
  2. Open Terminal
  3. Type sudo chmod -R 0777 /path_to_the_photos_folder {Press Enter}
  4. Enter your password {Press Enter}

Tip: After typing sudo chmod -R 0777, hit space, then drag the folder into the terminal window. This will “type” the correct path for you.

To read all the options of this command, in Terminal, type man chmod

*I always make backups of important files before trying something for the first time. Or if the files are irreplaceable. Or if I care about them at all :slight_smile:

Thanks. I tried that on a small number of files (all are able to be opened in Preview so I know there is nothing wrong in the file itself) in a new folder on the desktop and unfortunately the same result; i.e. the same error message.

Windows is the gift that keeps on giving.

Ok, you can open them in Preview. After opening one, have you tried to export it as a new file? What I’m thinking is, if you can and it fixes the problem, you might be able to use an automator action to covert them in bulk.

I happen to know a forum where some experts on automation hang out :wink:

Ugh, I have the same problem…


I have the same issue as @chrisa above. My files are all mine from previous Mac-formatted ext. HDDs…

Guess I’ll try going through the solutions above, but @chrisa, how did you end up solving the issue?


Mac Mini running Catalina connected to Drobo (where images live)


I have ~1.3TB of photos/videos, much of which I painstakingly extracted out of iPhoto when that app got too slow, but is also a consolidation of various external HDD’s (all Mac formatted).

I’ve been using a folder structure ever since. But while it’s great to be able to access every file directly, it’s not very good at actually LOOKING and SHARING the pics.

The new @MacSparky Field Guide (along with the companion MPU episode) sold me on Photos again (though I do so with some hesitation, given my iPhotos experience).

I’ve been methodically importing the folders and I get the same error message that @chrisa describes above.

I guess I’ll try all of these solutions, but what confuses me is that these are all my files and all Mac. Not sure why suddenly some of the files are randomly inaccessible while others in the same folder/roll are not.

Thanks to anyone who can shed some light!

Photos seems to choke on big imports. I’ve seen cases where repairing the photo library may help, as well as importing in small batches.

I ended up doing them in small batches. Made what in theory should be a simple task for a computer very laborious.

That said, I’m now in the process of moving them out of Photos and into Lightroom :stuck_out_tongue_winking_eye:

Many thanks @ismh!

I’ll take a look at using the repair tool.

Thanks @chrisa - what ended up making you jump ship?

I needed a way of curating them all, there’s a lot (c 90,000). Whilst I could do that within Photos I’m finding it easier to do it via the two apps. I’m moving them over and processing them in chunks. I prefer the Lightroom library module to manage large number of photos and the face recognition is really good.

1 Like

I’ve had this issue too, and ended up doing just this. Really though, shouldn’t this “just work”?

Yeeeeep. It’s really a frustrating bug.

Ha! Meanwhile I’m trying to get out of Lightroom cause I’m sure the clock is ticking on them slowly deprecating LR classic and I really can’t justify paying the CC subscription for my usage levels. It’s also annoying managing two libraries (Photos and LR). Really, I just need to learn Pixelmator and recreate my LR presets.