Problems with USB Hubs and M1 Macs

Problems with USB Hub and Macbook Pro w/ m1 and Monterey latest

Sometimes devices randomly not recognized or ejected etc.

Example : my usb Mac keyboard stopped working after a few hours. Complete power down and restart did not help.

Then tried OLD usb hub and keyboard did work - then keyboard with new hub did work the next day. Pretty crummy reliability…

Seem to be fairly wide spread in forums etc.

What is going on? Anyone else?

An I.T. buddy has this problem with clients with other M1 macbook and Mac Studio etc

This is the one I bought…


Curious. I have a Studio with four dedicated hubs (one of which is a Thunderbolt hub) and three displays with hubs with all but three ports in use. And I do not experience any such issues. (There I just jinxed myself!).

Two of the dedicated hubs are powered (the displays are of course powered), two are not. Two are USB only, one is Thunderbolt, one has a variety of ports.


  • Sonnet Echo 5 Thunderbolt 4 Hub
  • Satechi Type-C Aluminum Stand & Hub
  • Sabrent 4 Port USB 3.0 Hub
  • An old HooToo Hub with seven data and two power only ports (I don’t know the model; I think I was using it with my 2010 Mac Pro, via a PCI USB3 card - the good old days)


  • BenQ SW2700
  • Apple Cinema Display 20"
  • Apple Cinema HD Display 23"

I did have a couple of hubs that caused Bluetooth issues, but those have been retired. But no USB related issues. The Sabrent hub is even connected to the Satechi hub.

Not sure if any of this is useful to you.

1 Like

No problems with USB hubs here with an M1 Mac Mini, 2 x Anker USB A hubs which work perfectly.

1 Like

Thanks for the details.

1 Like


I do have a bit of a Franken-hub setup: Thunderbolt cable from MacBook Pro (original M1 model) to Studio Display. OWC USB-C Hub hanging off Studio Display.

It was all working fine for a few months after getting the Studio Display then recently I started finding my Stream Deck would go blank when I answered a Teams call using my (USB) headset! Given I had spent considerable time setting up the Stream Deck with buttons to control Teams this was suboptimal! I had so far put this down to the particular (high power, front) port I had my headset plugged into.

I quit using the headset (just using the SD mic/speakers) and have not had issues, except when I attached an old SSD for a pre-Ventura backup and it kept “unplugging” itself. I.e. I’d get the “you really shouldn’t do that” notification.

This is all recent so I am suspecting the OWC Dock is ageing. However, that same SSD and also a WD MyPassport Wireless Pro drive I have refuse to work if I plug them directly into the laptop. I have a cheapo StarTech “travel hub” I keep in my bag. If I interpose that between either of those drives and the laptop, they work fine. It’s kind of like a fake dongle. Both of those drives worked fine connected directly to my prior 2016 MacBook Pro.

M1 USB is a house of cards, I reckon.

1 Like

more issues here: