Random Cursor Movements when typing on Mac

Several Macs here - iMac 28" 5K, Mac mini, and a MacBook 12" laptop. All running High Sierra, all exhibiting the same problem -that the cursor can make apparently random movements away from the current typing point whilst the keyboard is in use.

These cursor-movements appear to result from key mis-hits, although I am unable to definitively prove this. “Mis-hits” encompasses things like touching multiple keys and even, it seems, a less-than–positive touch or and edge-touch on a single key.

The problem seems to be MacOS-related, and seems to have snuck in some time between Mavericks (probably later) and Sierra (possibly earlier) - I wish I could be more specific. It does not appear to be hardware- or keyboard-specific, as it affects all my Macs, with no difference whether I am using the laptop keyboard (where applicable) or any one of my selection of USB and bluetooth keyboards.

Has anyone ever found a solution to such problems?


I’m encountering the very same issue on my 27” 5K iMac running macOS Sierra 10.12.6. Can’t recall exactly when it actually started but I have the impression it was after upgrading from El Capitan.

It’s pretty annoying as I have to constantly watch the screen when I’m typing as the cursor has a tendency to jump back into the preceding text, sometimes the same line, sometimes a line or two above.

Unfortunately I haven’t found a solution yet and haven’t had the guts to do a complete wipe of my system.

FYI: The issue survived an in place macOS Sierra reinstall from the recovery partition (reinstalling the system files while keeping the data and user accounts intact). Have not experienced the issue on my 2011 MacBook Air running the same version of macOS though.

Just out of curiosity, what’s the mouse input device on your Macs and are you using Tap to click on your trackpad (if you have one)?

The same thing happens on my Macbook Pro, but since it does not happen on my (still going strong 10 year old) mac mini, nor on my ancient iPad Air, I have always chalked it up to user error.

I do not have Tap to Click enabled.

I get this with my 2017 15 inch MBP, but I’ve also chalked it up to errant palm or finger drags on the massive trackpad, since I have tap to click turned on. I’ve turned it off a couple times, but I’m so accustomed to tap to click I always turn it back on.

For the record, I don’t think it will help you to do a full wipe. I was having this issue on a MacBook Air on High Sierra, which I was forced to replace (MacBook / Tea interface …) with a new MacBook 12", also on High Sierra. The new machine had this problem out of the box. I didn’t migrate anything to it, but installed things from scratch. It still does it. I’m convinced this is baked into the OS itself.

1 Like

I have tried Magic Mouse and Magic Trackpad (not the latest version of either), and the built-in trackpad on the laptops. Problem applies in all cases. I do not have tap to click enabled.

maybe you’re invoking mousekeys using an accessibility shortcut?

Otherwise, have your tried having someone else use the machines?

Same problem on be MacBook pro 13 touch bar in clamshell using magic keyboard and mouse.

I thought it was user error as well but now that you mention it, I can see that it’s probably fine weird is error.

Exact same problem on 15" Retina MBP with a Magic Mouse. I thought it was user error for a long time, but I have concluded that it has to be the OS. I happens with and without a wired Apple keyboard and while connected to (but obviously not touching) the home and the office mouse.

Your suggestion - or something like it - was what I originally assumed was the problem. However, Mouse Keys are OFF, and I’ve spent quite a lot of time trying to find anything similar, but no success.

I have mentioned, I think, that my wife has the same problem on her new MacBook 12", but didn’t on her old MacBook Air that never got updated beyond Mavericks …

Further to this, has anyone tried using a non-Apple keyboard?

Did it make any difference?

I had the sudden thought that I should see what happens with a non-Apple keyboard, and realising that I had an old IBM keyboard stashed away I retrieved it and connected it to my MacBook 12". I got a system message asking me to help identify the keyboard, by pressing the button to the left of the space bar, and after doing so was then told the keyboard was now identified. I then started typing a few paragraphs of text, and completed it without any mishaps! Puzzled, I disconnected the keyboard, and typed the same text again, this time using the MacBook’ own keyboard. I made more mistakes this time around, because I the new MB keyboards really are horrible to type on, but still no unexpected cursor movements 2 hours later! Mad, but true … ! :slight_smile:

I shall wait and see if this is a permanent fix (it seems pretty unlikely, but it’s working so far!), and will keep you informed.

When the symptom reappears, you could try running Karabiner-EventViewer. This will give you a log of all keystrokes. If there are aberrant keystrokes, they would appear in the log, along with the other keystrokes.

It is 't. :frowning:

Back to normal now. No surprise there, then. :slight_smile:

Thanks. Now installed, so I can give it a go …

My 15" 2016 MacBook Pro does this occasionally, but never when I’m using an external keyboard and monitor. It only happens when I’m using the built-in keyboard. I figure I am accidentally touching the trackpad. I do not have tap-to-click enabled. It doesn’t happen all that often though, enough that I’ve noticed, but not enough to be a real bother.