Reconnecting to Synology NAS After "sleep" seems impossible : Fixed

I have a Synology NAS with an iMac and Macbook Pro. I mount with SMB routinely, but AFP is also enabled on the Synology. Running Big Sur 11.1 and up to date OS on Synology. On reboot of my computers, connections work fine. Should the machine “sleep”, on “awaking” the mounts are no longer there and I find it impossible to re-mount them using Finder of “mount” command inside the terminal. I have both Automount and Mountain to help me with these mounts and neither can do the remount (I don’t run them at the same time in case that an issue).

I could just not “sleep” the machines I guess, but it doesn’t seem like this is right.

Synology support (via chat) had no suggestions other than since neither AFP or SMB work on re-mount after sleep, problem was with Apple and I should call them. I’ve not yet done that as i fear they will lead me down a rat-hole with the final recommendation to re-install the OS on both machines.

Any suggestions?

What happens when you try to mount them?

Beachball … Same even when using the Apple Script “mount” command (I had the idea to have a script for all shares I want and run it, but that didnt’ work).

Automount reports “mounting” for a while, then gives up and says “mount timeout”

Are you aware that Big Sur does not support afp?

did not know that but it is irrelevant as i use SMB. i only tried AFP in an attempt to debug.

1 Like

I read the article … it appears (reading it correctly?) that AFP to “share” outgoing mounts to the network from a Big Sur mac is what doesn’t work.

Glenn says “(Big Sur can still mount AFP-shared volumes.)”. I’m not doing that.

At most I thought turning afp off on the Synology might be worth trying. But I posted it just as general information. I stopped using AFP years ago.

2 Likes

I thought of that too and tried it … but then the box told me that TimeMachine would be inhibited.

I fear it’s an unsolvable problem, and related to something in the Mac’s operating system that doesn’t gracefully come out of sleep.

I’m going to try turnning off sleep for few days and see it the mounts retain.

1 Like

My 2018 mini has ignored the sleep settings in Energy Saver since day one. I have to use the Amphetamine app to keep it awake.

1 Like

What version of SMB are you supporting on your Synology?

I have Max SMB 3, Min SMB 1 (to accommodate some iOS apps)
SMB Range SMB1, SMB2, SMB2 and Large MTU, SMB3

Also:
Enable Opportunistic Locking
Enable SMB2 lease

No issues with Sleep, Mount. Remount, etc., etc.
Mix of Catalina, Big Sur, Yosemite, MBP, MBA, iMac and Mini

1 Like

Good news: My settings same as you.

Bad news: My settings same as you but you don’t see issues.

I did install Amphetamine as WayneG has … symptomatically the iMac hasn’t slept and the mounts still there. Sleep may or may not be root cause.

How about “DNS” type settings?

Workgroup in Synology SMB settings the same as
your router, and your Mac(s) DNS search domains?

Trust your NAS IP address is static?

static IP. i will have to check DNS addresses, but that surprises me that all to be same.

tomorrow. thanks.

Not DNS per se, more along the NetBIOS, Workgroup, etc. info.

Makes sense re DNS. All using the default named WORKGROUP and other things I’ve checked seem all in order.

Letting a machine fall into sleep overnight connection lost. Other two devices with Amphetamine on and no sleep kept all mounts overnight.

Sure seems to be related to something stopping a gracefull wakeup.

Close Out Report

The problem/symptom was on two machines–iMac and a MacBook Pro both with up to date OS’s failing to activate mounts (shares) with a Synology NAS (relatively new with up to date OS) on waking from sleep. Before going into sleep, all the mounts worked well. On waking the machines would not recognise the mounts. The Automounter app said “Mounting…” and would eventually time out. The Mountain app didn’t respond. Using the “mount” command in the Terminal would show the shares mounted. Finder would “beach-ball” when clicking on the server. The only way to resolve things I could find would be to re-boot the computers.

I assumed the problem cause resided with the Macs OS or the NAS. I rejected thinking it was hardware related since the odds of failure on the two Macs was low. Cast out for ideas here and with friends. Only when @csf111 came along (after I had given up!) and logically going through it was the role of the Netgear GS108 network switch considered.

@csf111 suggested changing a couple of settings on the switch, assuming it was a “managed” switch. It wasn’t. The GS108 is an unmanaged switch. So to enable this path of solution to progress I purchased a new GS308E Netgear managed switch (8-port) to replace the GS108. Simple to replace–just start up the new switch, move the Ethernet wires. Shutdown and store the old switch. Simple.

I ran a number of tests to try to ascertain which of the settings suggested by @csf111 might be the culprit. All those tests I did, with erroneous conclusions, were flawed (didn’t realise it at the time) because it did not occur to me to have to re-start the switch between changing the config settings. The switch’s web page didn’t remind me, not that it was Netgear’s fault to not tell me that. These flawed tests suggested things working, but turned out not. After an over-night sleep, the “beach-ball” returned on the iMac. It occurred to me that my tests were flawed since I did not re-boot switch between changes. Yes, slapped my head in disgust with not thinking of that!

New switch settings:

Broadcast filtering: enabled. Enabled out of the box.
IGMP Snooping: disabled. ← believe this the critical change. Enabled out of the box.

On re-starting switch without re-staring either Macs, mounts came back “automagically”.

Conclusion: IGMP Snooping must be “disabled” on the network switch connecting the Macs with the Synology NAS, else proper “waking” of Macs from sleep won’t reconnect reliably and/or at all. @csf111 explained what “IGMP snooping” is:

At an abstract level, IGMP snooping monitors IP
multicast traffic. SO, it watches the “dialog” with
all your mounts, and after a while goes, “Ah, you
haven’t used these in a while, shut’em down Dano”

I did not investigate Broadcast filtering (the other setting change suggested by @csf111) having decided to leave well enough alone now as all seems to be working.

Happy camper. Thanks @csf111

6 Likes

Odd, I’ve just connected to my synology share from Big Sur using afp
afp://DS9._afpovertcp._tcp.local

AFP 3.4, last released in 2012, is still supported on HFS+ volumes but not on APFS. And recent versions of macOS will not use AFP to share files with other Macs. You can still connect to an HFS+ volume using AFP if the device firmware allows it.

1 Like

It’s been a minute, but from my recollection, I was advised to enable afp to support locating shares, and to only use smb for mounting those shares.