Refoss Mini Smart Plug Help

I recently purchased a pack of 4 Refoss Mini Smart Plugs off Amazon. In reality it appears that these are a cheaper version of Meross plugs. Anyone else have experience with these? I am about to send them back as I cannot for the life of me get them to pair with HomeKit even though they are supposed to be HomeKit compatible (which is why I bought them). Here is what I have done:

  1. I have disabled the 5GHz wifi on my network so that my iPhone 13 Pro Max running iOS 15 is connected to the network using 2.4GHz wifi as required.

  2. I have also verified that the the mini smart plug is connected to the network and the LED is blinking amber/green indicating that it is in setup mode.

  3. I have attempted to add the accessory both directly into HomeKit (which the manual says you can do) and through their iHomeLife. Each time I try to add the plug I get an error stating that the “accessory is not available.”

  4. I have repeated attempts to add the plugs after resetting my router as well as doing a factory reset on the plugs. None of this has worked. Ocassionly, but not always, I will hear the plug turn off then back on during attempts to add it to HomeKit but installation never completes.

Here are my suspicions:

  1. For some reason the plugs are not compatible with iOS 15. Have you tested this?

  2. My network is a mesh system using three Amazon Eero Pros and am wondering if the mini smart plugs have issue with this. This has never been a problem with any other accessory I have added, but these are the first that do not require a hub which might be part of the problem. I have attempted adding the plugs to HomeKit when I know that both the plug and my iPhone are connected to the same Eero Pro.

Any thoughts anyone might have would be appreciated.

I use both Refoss and Meross plugs with very little problems.I also have Eero and iOS 15 so that’s a bummer you are having such a hard time.

The only thing I can see that I do differently is I use the Meross app, even for Refoss products, because I assumed they were the same under the covers. It hands the setup off to Homekit , but I have that ehomelife app downloaded and it has zero accessories added so maybe I tried it with no luck and forgot. Maybe try the Meross app after factory resetting a plug?

One other thing to mention is the support teams for both products have been surprising helpful. I had a wall switch fail mechanically after about a year, which Meross replaced. And I needed help setting up another Refoss product and they sent me detailed instructions.

I have struggled with “smart” device setup so I definitely feel your pain.

1 Like

Thanks! I will try the Meross app. Have sent a detailed message to Refoss support but have not heard back.

Thought I would post a follow up on the issue I was having with the Refoss/Meross smart plugs. Ended up returning them to Amazon since I never could get them to work. Ordered a couple of Vocolinc plugs to try on a recommendation. They came today, took them out of the box, did a quick reset on the plugs, and they installed without issue. The Vocolinc plugs were less expensive (if you buy a 4 pack, about the same cost if you bought the 2 pack as I did) but feel better made. Installed them directly on HomeKit but the Vocolinc app recognized them just fine. Also like the fact that The Vocolinc app does not require me to set up any sort of account when using HomeKit. Thus far I am really pleased with these plugs!