Remap function keys on magic keyboard?

Is there any way to remap the magnifier key, (and/or the brightness keys) on the Magic Keyboard with Touch ID natively?
I would probably be able to do it with Keyboard Maestro or the likes, but I was wondering if it’s possible to do natively before I install one of the third party apps.

I would like to use one of the keys to view the desktop.

1 Like

there’s a native way, forgot what is it called.
might be easier with keyboard maestro or karabiner elements

Navigate to Preferences > Mission Control, then in the Keyboard and Mouse Shortcuts, click on the Show Desktop dropdown list and pick the function key you want.

Note on my non-magic keyboard I need to press the “fn” key and the function key for this to work. So in the example shown in the screenshot I need to press fn-F1 to show the desktop.

Hope this helps.

1 Like

Yes, I can get that part to work, and I suppose it’ll do for now. The next level that I ideally want is that I don’t have to press the function key. I don’t use the brightness keys or the Spotlight key, so I had hoped they could serve other purposes without too much fiddling with 3rd party software.

If this doesn’t work for me, I’ll just get Keyboard Maestro. I’ll probably find good use for that elsewhere, too.

I use Karabiner.

You can have multiple profiles reassigning multiple functions to the same key and switch between profiles as you need. It’s not a replacement for Keyboard Maestro, but if all you want is to reassign keys to existing function, that’s what I would use. I think it’s free.

EDIT: but Keyboard Maestro is awesome, totally worth it in the long run :grin:


I was able to get a function key, in my case F1, to show the desktop without using the fn key.

To do so I used an Apple USB keyboard, I know not what model nor when I acquired it (perhaps with my 2010 Mac Pro?). It does not have a fn key.

I also set the “Use F1, F2, etc. …” checkbox to checked in System Settings > Keyboard > Keyboard:

My Satechi bluetooth keyboard, which does have a fn key, requires the fn key to be pressed to make this work.

Seems to me that this is a bug in how this parameter is supposed to function (pun!).

Update: I tried to set this up in Karabiner Elements and was not successful. I am by no means well versed in the ways of Karabiner, but I tried several ways and came up empty. This was one set up:

Where I attempted to map F1 on my Satechi keyboard to the expose desktop keycode. I also tried this for all devices.

A puzzlement for sure.

I think you need to uncheck « Use all F1, F2, etc. Keys as standard function keys » in Karabiner, otherwise, it’s going to use the standard function (ie. do regular F1 things, not « mac » things). At least that’s the setup I have (it’s unchecked). But then if you want to keep using special functions (ie. whatever is drawn on the Apple keyboard) with the other F keys, you have to remap them as well otherwise they’re going to do nada.
I remember having to play around with that checkbox to get things to work how I wanted…

EDIT: clarified my initially confusing explanation….

If you never want to press the function key (and by this I assume you mean the “fn” key), you can do that with the keyboard preference mentioned already.

If you want to control this on a per-application basis, there’s Fluor.

I tried Fluor, at least I tried to try Fluor. When I attempted to launch it I got a ‘server not found’ error (I do not recall the exact text) and then nothing. It was running but presented no UI at all. I had to restart my Mac to get to clean things up.

That’s odd, I’m using it with no issues. Although, its only UI is in the menu bar.

Edit: Are you using Karabiner Elements? There’s a reported issue regarding Fluor and KE on the GitHub pages.

Yep, I’m using Karabiner. And it is working for other things, just not for the function keys. I might do some more investigating this weekend.