Remapping Command and Option keys on bluetooth keyboard in MacOS Ventura

I am using a Jelly Comb bluetooth keyboard with my 16" MacBook Pro M1 Pro. For whatever reason the command and option keys on this keyboard are reversed. Under Monterey it was a simply matter to remap the two keys so that they worked correctly. I just installed the public beta for Ventura today and lost the remapping of this keys for the keyboard. When I went to system settings (formerly preferences) the option to reassign the modifier keys appears to be missing. Am I missing something?

Well, in case anyone is interested I actually solved the problem. Changing the modifier keys was, for whatever reason, burried deep under keyboard shortcuts in the keyboard settings. The logic behind that escapes me. Also odd is that my issue was caused by the remapping of the command and option keys that I did in Monterey. Seems in Ventura the keys returned to being mapped correctly so I fixed that and all is well.

This is madness… absolute chaos.