Reminders “deleting themselves” (!) from Family list

Hi all. I guess ‘tis the season for spooky, unexplained happenings in iCloud-land.

Earlier today I realized that all reminders in my Family list (shared with my wife via iCloud) are disappearing a few minutes after entering them. I literally watched some of these entries get deleted in front of my eyes! This happens to reminders entered by me or by my wife. It happens to reminders entered via iPhone, iPad (both on iOS/iPadOS 15.1) or MacBook Pro (Monterey). It happens to all kinds of reminders (with assigned dates, assigned times, or simply unassigned details). This functionality worked well prior to iOS 15.

Oh, and reminders entered in the “Personal” list seem to be OK. They stay on the list, and sync to all other devices.

Can someone be kind enough to test this on your end? Simply add a reminder to your Family list, give it a few minutes, and see if they’re still there after that time. I’d like to hear from the community before I begin more drastic troubleshooting steps on my setup.

Thanks in advance for your help!

I have the exact same setup with a shared reminders list with my wife. Just tried this very thing and after 30 min or so, the reminder happily remains. I only tried a simple one with no dates, tags or anything else.

Both my wife and I are on iOS 15 on our iPhones and iPads. My MacBook is Monterey, while hers is currently still Big Sur.

I guess if nothing else, this suggests some troubleshooting will be needed on your end.

The only thing I can think of is to check for other apps that have that shared reminders list set up as the one they watch and then ‘import’ any new reminders into the app. A few of the todo apps do this as I am sure you’re aware. That’s the only thing I could think of but it still doesn’t explain why it’s only started happening to you in iOS 15.


This would absolutely be my guess too. OmniFocus, Due, Drafts, and many more will import tasks from a list.



Yep, that was it!

It turns out one of us had switched on their Reminders Capture setting in OmniFocus. This had happened quite recently and was done inadvertently. We had seen the “deleted” reminders pop up in the Forecast view in OF and it didn’t occur to us that that may be the culprit. Switched that off and shared reminders are happily sticking around in the Family list once again. Thank you @kjw97 and @RosemaryOrchard for your help!