Remove DRM from Kindle in Catalina: anyone use Epubor?

My old method was to use Apprentice Alf’s DRM removal tools running under the older rev of Kindle app. Procedure was to download books in old kindle app, I had a Hazel job watching the kindle folder and copying the various book format files into a convert folder and a Calibre process to automatically run the items in the convert folder through de-DRM and bring them into my Calibre library. Not to steal or hurt any authors but because I want a free and usable copy of the books I buy.

Old revs of kindle app don’t work on Catalina and the new file formats are all DRMed even from publishers who have said no to that outdated technology.

I tried the suggested new replacements: Download from the web to an old kindle device using the feature to transfer by USB to get an older .AZW format file. Updated the de-drm plugins in Calibre to the latest versions but they still won’t remove the DRM.

I found references to some tools from a company called Epubor but not to sure about them and want some info from other users first.

Or any other suggestions.

This isn’t really a direct answer to your question, but a bit of info just in case it’s helpful. (When I was trying to get Apprentice Alf’s tools working I also came across Epubor in my searching — and I was a bit wary, too. Given some of the comments in these MacUpdate comments — particularly the ones from 2019, wariness is probably in order.)

Anyway, for the info: your post sent me to try to remove DRM from the books I most recently purchased. I downloaded the files for USB transfer and imported them. I then converted them to EPUB format to confirm that the DRM was removed. I didn’t run into any issues, and I’m running Catalina. I have an e-ink Kindle, though, so I was able to use the serial number from that.

Are you using an e-ink Kindle serial number in the plugin? If so, is there any possibility that it’s from a Kindle that’s too old to handle the current file format?

There’s some discussion of what looks like a similar problem in this GitHub threadElleKayEm’s post might be helpful. There’s some additional discussion in another of Apprentice Alf’s GitHub threads.

Given that Amazon currently has their cheapest Kindle on sale for less than the normal price of a (possibly sketchy) Epubor license, acquiring one to get a current serial number may be your best bet.

And if you do happen to have an older Kindle lying around, you can get an even better deal — Amazon’s running a trade in and get 25% off promotion.

As far as I can tell, a Kindle Keyboard still works as a trade in for that purpose.

I’ve never tried to convert to epub first. Can you perhaps provide a more detailed set of instructions?

Yes to both perhaps. I used my original first generation Kindle. We’ve got 2 of them. We actually use them still. Hubby has replaced the batteries on them and done some other work but they both still run just fine. I do have a paperwhite but it’s on loan to a friend who shares our tastes in books. I figure it’s about like having a kid on your book account so I send things to it that I know he will like.

I can’t dive into this question again today but I may have some time again tomorrow. I’ll post back what I find out.

Sorry, I should have been more clear. I ran the de-DRM first by importing the book to Calibre with the plugin already correctly configured.

I then used Calibre’s conversion tool to convert to EPUB, just to confirm that de-DRM had actually worked. The conversion tool throws an error if the file still has DRM on it. (The conversion button is on the left side of the toolbar, at least in my installation. Clicking it with a book in Calibre’s library selected brings up a dialog box where you can tweak the settings; options for the output format are at the top right.)

Good luck! You may need nothing more than to have your friend look up the serial number of the Paperwhite and send it to you. :smile:

Odds are your physical Kindle is too new (with a too-new O/S update) to directly work with DeDRM. That’s why many of us use the legacy Kindle Mac desktop app, and why the move to Catalina (which means that Kindle app no longer will run) is a big issue on this front.

I too am wary of Epubor…

My plan is to keep a machine around for a while (maybe a VM) to keep this pipeline running.

Thanks — but my Kindle (an Oasis, 2d generation) works just fine with Apprentice Alf’s tools on a Mac running Catalina. Maybe I’m just unclear on what you mean by “directly work.”

I’ve got the plugin configured in Calibre. Then I just download the file from Amazon for transfer via USB, drop those files into Calibre, and I’m good to go.

A Kindle is my normal reading device, so there’s not a lot of practical difference for me in whether my Kindle books are deDRMed, but I want the freedom to move to another device for personal use of my purchased books if I ever decide to do that. So what’s on my Kindle is probably a mix of books with and without DRM.

A side note: My first ereader was a Nook, and getting those purchased books to my Kindle was the primary practical reason for getting into Apprentice Alf’s tools. Getting the BN plugin working was quite a saga, and much tricker than getting the Amazon plugin working. It involved Android Studio and a virtual device…

My knowledge may very well be dated and I have a todo to dig in further. Last time I checked, the direct transfer from Kindle --> Calibre with DeDRM only worked for books downloaded using Kindle firmware prior to version 5.10.2. I’m going to be very happy this weekend if I learn that this has been resolved.

I’m the OP and that is the issue I’m running into. I read on my iPad so I had a different set-up to De-DRM the books but it won’t work under Catalina. I do have an original 1st generation kindle and a paperwhite but even when I download the books for USB xfer using the paperwhite option the books do not have the DRM removed. This is even on books that the publisher has said are being sold without DRM.

I confirmed that the latest DeDRM tools work for me - thanks so much @acavender. It isn’t always seamless, e.g. sometimes the books downloaded from Amazon don’t have the proper extension, but at least it is working and I can move forward on Catalina.

@OogieM - did you configure the tools with the serial number of your Kindle Paperwhite? If not that could be the issue.

I’m glad it worked for you!

Also, just in case you haven’t already discovered this: the files that download without the correct extension are azw files (I ran into this, too). Just tack the extension on manually and you should be good.