Reset Mail cache on iPhone? Can't delete messages

I have two messages that, not matter what I do, continue to reappear in the inbox on my iPhone.

  • Exchange account
  • Messages are in the inbox for the Exchange account
  • iOS 13-specific
  • Not the only account in Mail
  • Messages appear only on the phone, but not on iPad or web or office PC
  • can “delete” the messages, but they immediately reappear and do not show up in deleted messages
  • can “move” the messages, but (again) they immediately reappear and do not show up in the target folder.
  • read/unread status can be changed

I suspect this is just some cache issue that needs to get flushed out. But I’m not sure how to do that on iOS. I’ve tried going to settings for this Exchange account and turning off Mail, waiting for a while (using other apps, using Mail, etc.) and then turning Mail for the Exchange account back on, but the messages survive.

Any suggestions for additional measures short of resetting all settings? I’d prefer not to have to go to the trouble if not necessary.


Have you tried deleting and recreating the Exchange account in Settings/Passwords & Accounts?

We didn’t use Exchange but that normally fixed mail when one of my users had a problem that the usual tricks couldn’t cure.

1 Like

Thanks, that did it.

Any tricks to get all the mail re-downloaded efficiently? I’m just going mailbox by mailbox to hopefully get that started for each.

Your Exchange account page should have a “Days to Sync” setting that limits the amount of mail downloaded. The default setting used to be something like 3 days to prevent filling up your phone with old mail. There should be multiple settings including Unlimited.

Thanks again. I was aware of the setting, but in practice, you need to open each folder to initiate the download of the associated emails. I was hoping to force that to happen efficiently rather than having to open each folder individually to start the associated download.

1 Like