Router and switch have the same address (?)

I have a TP-Link router, it’s IP address is

I ran out of ethernet ports, so I got a 8-port switch, also a TP-Link. I read this in the instructions: “Visit the Web-based GUI with the default IP address of the switch and log in…”.

I thought that was strange so I visited and got the router admin page, as always.

Quite a bit later, I repeated the above and was greeted by the admin page of the switch! Additionally, at this time my network was acting funny.

I read the switch instructions again and saw “It is recommended to configure the IP address of the switch properly to avoid any IP address conflict…”.

The only way I could think of doing that was to use an address reservation in the router, which I did.

I assumed that the switch would get its address from the DHCP server, did I assume correctly? I can’t reach the switch admin page using the address I reserved for it, but, so far at least, I haven’t had any other weirdness.

You should get back to the switch admin page if possible and either configure a different IP address in the same subnet or better still configure it for DHCP.

If you can’t get to the switch we can get there a different way.

1 Like

Apparently it is configured by default to use DHCP, and then fall back to the fixed address if it can’t reach the DHCP server. Why they picked .0.1 makes no sense to me, though.

At this time I cannot get to the switch admin page. The DHCP client list does not show the switch’s MAC address. I can’t ping that address either.

Well turn off your Wi-Fi (i assume you are using Wi-Fi) and connect the switch to your Ethernet port on the Mac.

Create a temporary Ip configuration on the Ethernet port (in network prefs) with a manual address of 0.2. Mask of

Now go to 0.1 in your browser. Give the switch a fixed address in the subnet that is not in your dhcp range like 0.75 or something like that.

Go back to your standard ip config and turn off Wi-Fi…

I wasn’t using wifi, I was using my Mac wired to the switch.

If I understand you, you’re suggesting disconnecting the router from the switch and then trying 0.1 ?

Yes, best way to fix this is to temporarily disconnect the switch from the router and connect your Mac to it directly (sounds like it already is).

If your Mac already has an IP via DHCP, chances are it won’t lose it when you disconnect from the router unless you unplug the Mac’s network cable or restart network services on the Mac. Worst case, manually assign an IP to the wired interface then connect to the switch IP and change it’s address.

Tried it, no luck. Can’t even ping it. This thing may be on its way back from whence it came.

You could try disconnecting everything from the switch and power cycling it. Alternatively, do a factory reset of the switch with nothing connected to it. Then, once the switch is fully booted, connect just the Mac (call nfigured with a static IP on that subnet but not and try to connect via browser.

Out of curiosity, what model is the switch? Does it just have the 8 Ethernet ports or are there serial and/or SFP ports?

An unmanaged switch might be a better fit unless you need the extra capabilities managed switches provide).

1 Like

Yeah, that might be worth trying. I’ll report back tomorrow.

The model # is TG-SG108E. It has only Ethernet ports. It calls itself a unmanaged "pro” switch. I really wanted just a plain unmanaged switch, I wouldn’t have bought it if I had known otherwise. is commonly set as the default IP for network gear. Strange that the switch can’t reach your DHCP server though… if that was it’s first preference, it seems it would be able to find the DHCP server on the same Ethernet segment. As others have said, you should be able to just assign it a different address manually, and then reserve that in your DHCP server to avoid any future conflicts. At home, I have my few pieces of network gear at low addresses (set manually), computers and phones will get addresses from .100 to .199 through DHCP, while IoT devices like my surveilance cameras and stuff start at .200, also manually assigned. No particular reason for this, other than making it possible for me to actually remember some of the IPs I very seldom need to log in to.

@JoePreiser’s suggestion did work. Thanks everybody!