ScanSnap S1300i failed update of ScanSnap Home after updating MacOS to Catalina

I’m new to this community—drawn here because I see some older posts addressing troubles getting ScanSnap Home to work. Has anyone seen and solved the following problem?

I have been using a ScanSnap S1300i successfully for many years with an iMac. Based on the notice I see here

I upgraded my iMac to the Catalina OS, and then I installed ScanSnap Home. I am repeatedly getting this error “The operating environment of the program is abnormal” as shown in the attached screenshot.

I have tried the following to address this

  1. Used the Clean My Mac program to ensure the earlier version of the scansnap software was removed, along with all its accompanying files

  2. ensured during ScanSnap Home installation that the application appears in the “Full Disk Access” Privacy list for the iMac, as instructed here

  3. used the “check for updates” feature of the ScanSnap Home program to download and install an update

Update: It appears to run correctly in a newly created account on the same IMac. I’m looking to see what’s interacting improperly with it in my preferred account.

Always a good troubleshooting method. Welcome to MPU!

Try this.

  1. Quit the app. Make sure that it is fully quit (no menu bar or background processes running).

  2. Drag the app from /Applications/ to your Desktop or Home.

  3. Drag it back to /Applications/

I’ve seen this solve similar issues. Catalina has some extra hidden protections against apps that are automatically added to /Applications/ and wants to make sure that the user wants them there. I wouldn’t be surprised if Fujitsu wasn’t doing it properly or if Catalina just got confused.

Thank you, I hadn’t thought of that. That didn’t fix it but it provided an additional clue. After dragging the app out of /Application and then back in again, it then exhibited the same error message in the newly created account as well as my established account. A reinstall of the app got me back to the state where it succeeds in the new account and fails in the established account.

When you moved the app out and back into /Applications, did that break the “Full Disk Access” permission?

Fujitsu phone support provided a solution. Suspecting that the ScanSnap home configuration file collection in my normal-use Mac account was somehow corrupted, they had me clear these files (under ~/Library/Application Support/FPU) away, forcing a reconfiguration. This worked, although with the minor consequence of losing scanner profiles.

From the Fujitsu support follow-on email

  1. Close out of ScanSnap Home
  2. Click the Apple icon and do a force quit and look for anything SanSnap and quit it.
  3. Click on finder icon in your dock tray.
  4. Click Go at the top of the screen and then select Go to Folder.
  5. Type ~/Library and click enter
  6. Then go to Application Support
  7. Rename the PFU folder to PFU Old
  8. Then relaunch ScanSnap Home and go through the scanner selection process