Screens and Eero

Is there some trick to getting Edovia’s Screens remote access software to work through an Eero router that I’m missing? I have a 2018 iMac running Big Sur on an Eero network, hardwired through a switch. The eero is acting as the router and the modem is in bridge mode.

I can access the iMac with my MacBook Pro running Big Sur just fine while on the same network, but I can’t get to it the iMac from outside the network. I have tried Screens Connect configured both automatically and manually (public port 2299 to port 22) with the eero set up with a port forward for the iMac), but it doesn’t connect. No error message, just never connects.

I’m trying to access through hotel wifi. The iMac is set NOT to sleep. VPN is not running on either computer. Ideas?

I don’t often have to work away from home and access my home office remotely, so this is the first time trying to get this to work. (I can go home every few days to physically access the iMac to change configs, if I need to.) Thanks.

Have you forwarded 5900 to your iMac?
It’s the default port for SC unless you changed it.
You might also try a public port scanner to see what you have open at home.


Tailscale (terrible name) might be an option too.

1 Like

Eero is a compatible router acc. to Edovia. Pls check if the UPNP function is enabled on the router. This should allow Screens Connect to connect to the PC at home.

If not, or in case you don’t want to use UPNP, you need to follow the port forwarding setup. Make sure you give your iMac a fixed IP address on your router otherwise your forwarding might fail upon a reboot or expiry of the IP lease.


If you are using Screens Connect, you don’t need to use port forwarding. It should do it for you.

My suspicion is that the hotel Wi-Fi might be the issue. I’ve run into loads of issues on hotel Wi-Fi.


So UPNP was enabled. I never got Screens working but I tried Chrome Remote Desktop and it does work so I’m going with that. It could still be a quirk with the hotel wifi, but in the end whatever works. Thanks for the help though.

Sorry to hear you couldn’t get Screens working, but glad you found a workaround.

FWIW - I found Jump Desktop to be somewhat more reliable, but I have a suspicion that all of these services can be flummoxed by certain network configurations, so just depends on which ones each of us runs into!