Seagate HD with Thunderbolt to USBC not reading on new MacBook

I have an old Seagate HD that I used with Thunderbolt on a Mac Mini back in 2013ish time. I bought a Thunderbolt to USBC adapter from Apple but my 2019 MacBook running Catalina won’t read it. I get an error that says “The disk you inserted was not readable by this computer.” Then I have the options to Initialize, Ignore, or Eject. Nothing seems to happen when I choose any of those options. Any ideas on how I can make this work?

After you select Initialize, you then
need to format the disk

(Using Disk Utility or your favorite)

This usually happens when you have a disk
that has been used by another operating system.

(Windows has formatted NTFS, or Linux ext4, etc.)

That’s the only way? I don’t want to lose the info on the hard drive. I can’t think of how it would have been formatted for Windows. It’s a GoFlex for Mac and I never formatted it for any other system.

Well you could poke around with some
disk utility tools, but had you used the
GoFlex tools?

If I recall this drive had a set of Paragon
drivers that would allow you to use on
both Mac and Windows.

Maybe give them a shot? (But I think they
were 32 bit? so that would depend on which
macOS you are using…)

I went to Seagate’s website and the only tools they have available for the Mac are back up utilities. The drive shows up in my Mac disk utility but The only options there are Repair, Restore, Erase and are our doesn’t work.

GoFlex drives were formatted either with HFS+ (and came with an installable Windows driver PCs could access the files) or with NTFS partition and came with Paragon driver to be readable by Macs.

That doesn’t help me. It was initially bought as a “For Mac” hard drive back around 2014 and was connected to a Mac Mini, working just fine. It’s been sitting in storage since about 2017 and hasn’t been formatted for at other platform since.

Then it could be the cable or the GoFlex dock (assuming that’s the model), or even the specific port on the Mac (which would be the easiest thing to try changing). Or the drive deteriorated in intervening years on the shelf, which can happen.

FYI this guy had a relatec issue and took apart his drive to discover a loose USB connector:

1 Like

I’m hoping it’s not due to deterioration. That was one of my first thoughts. If it is, would I still be able to get the info off of it if I sent it in somewhere?

2017? :frowning: Certainly a candidate for bitrot

Agree with @bowline, try the obvious BUT
if it’s that important, there are data recovery
firms that are always willing to try

There are forensic tools, but I wouldn’t
recommend if this would be your first
exposure and the data is important.

Do you have any data recovery companies or software you would recommend?

The Cadillac of drive recovery companies is DriverSavers. Expect to spend several hundred dollars at minimum (though they’ll do a free evaluation). Lawyer friend with a home office had his PC crash, and without his knowledge his idiot son had taken his backup drive and overwritten everything with downloaded games and porn. He got everything back with DriveSavers (albeit without the original file names on most documents) but it cost him almost $1,000.

https://drivesaversdatarecovery.com/data-recovery-services/devices-supported/mac-data-recovery/

But you could try using a different cable first; that’s solved some people’s similar problems.

1 Like

I’m going to try replacing my Thunderbolt cable since it’s the original one for when I bought the device. After that I’m debating if I should try the thunderbolt to USBC cable or just see how much it will be to have the data recovered. There probably isn’t more than 1.5 TB of data on the drive.

A new cord didn’t do the trick so I’m just going to try and get the data off of it. Have you tried any of the at home software for data recover? There are a lot of options but I don’t want to waste another $60 on something that doesn’t work.

I’m not experienced with 3rd-party utilities that can mount otherwise unmountable drives, sorry. I haven’t used disk utils in a decade, maybe since Mountain Lion. Back then I’d bought (now incompatible) copies of TechTools Pro and DiskWarrior, and the other major app back then was probably Drive Genius. (No idea who’s good today.)

Did you check Disk Utility? When connected, is the drive icon (greyed out, probably) in the left column of the app? If so, try to choose it and Mount. Failing that, try selecting it and clicking First Aid. (If the external hard drive is not showing up in Disk Utility, it is very likely that your disk is suffering some physical damage.)

The three cheapest things to try are new cable, different port on the Mac, and trying to connect to a different Mac. I’d try to do all three if possible.

Actually there is a fourth that I found in an old Apple.com discussions forum: in Terminal type diskutil list and Return. It should show you a list of all drives in and connected to your Mac, even if they aren’t mounted. If it sees the external drive, note the number of the disk (far left column) you want to mount. Then, enter this command:

mount /dev/(number of disk)

The instruction is “Put in the number, no parenthesis. Press Return” but in my case it seems to be a name like “disk3” and not just a number. A more comprehensive (yet old) description can be found here and I’d suggest you check it out.

Another Terminal command option noted was

mount force /dev/(number of disk)