Self assigned ip address

Weird recurring problem: Every day for the past few days, at a certain point in the evening (around 10-11 PM), my M1 Mac Mini loses its connection to the network over both ethernet and wifi. Both services in the Network panel in System Preferences say “self assigned ip address”. A reboot solves the problem, but it comes back the next day.

None of the other devices on my home network – wired or wireless – have this issue.

The ethernet port on the Mac is connected directly to a TP-link modem-router. Wifi is to a TP-link Deco mesh network (main Deco is M5 unit sitting right next to the Mac Mini and connected to the router via ethernet cable).

Given this problem is only on the Mac Mini and also affects both the wired and wireless networks (which are 2 different devices at the other end), I assume this is a Mac Mini problem and not a network problem.

Any ideas?

Is it exact the same time, or is it around a time-frame?
Is there, or can you activate, a protocol on the Router, to see what happens before and after the disconnection?
What is the weather like in your area?
Is there a daily reconnect of the router with the external network? Some ISP require that once a day.

UPDATE: The problem was not happening at the exact same time every day, but at around the same time. It only affected one of the 10-15 devices on the network, and it affected that device on both the wired and wireless connection. The weather is consistent (hot and dry). The router does not reconnect to the ISP on any schedule.

I figured out that the problem was somehow connected to the renewal of the DHCP lease. The IP address would switch to “self assigned” at the time the lease was supposed to renew. It wasn’t the exact same time every day, because sometimes I would not notice the problem right away. When I did notice it, I would reboot the computer, which would temporarily solve the problem by getting a new IP address from the router, which would reset the lease renewal to 24 hours later than that moment.

I tried clicking the “renew DHCP lease” button in Network Settings, but that did not seem to do anything as long as the IP address was self assigned. If the lease was still active when I manually renewed, it would renew for 24 hours, which would just delay the inevitable (unless I would remember to manually renew every <24 hours).

What did seem to solve the problem was switching “Configure IPv4” of both Ethernet and Wi-Fi to “Using DHCP with manual address” and then typing in a unique IP address for each (choosing a number within the designated range which was not currently in use by another machine on the network).

It’s been several days now with no problems.

Is there any downside to using manual IP addresses?

Not on a Mac mini. I actually prefer knowing the IP addresses of my desktop devices. Good troubleshooting and solution!

Not to my knowledge.
I am setting up my networks always in that way, what keeps me also from searching, if I need to address a device by its IP.
I am doing this since the beginning of private networks, so somewhat since 20-30 years now, with zero problems (that I could blame this setting for!) at all.

While there is no downside to a manual IP address,
if possible, you should set it on the ROUTER.

This is done by selecting the MAC address of the
mac mini network adapter and assigning a static ip.
(Not all routers support this)

Just ensure it is NOT in your DHCP range.

To @Ulli’s and @Jezmund_Berserker points, I assign
all devices on my home network a static ip address.

Why should it not be in the DHCP Range?
Specially if you set it up within the router?

You want to be able to see WHICH addresses are “dynamic” DHCP leases.

SO, if you have “dynamic” DHCP - and everything
else “trusted” with static IP addresses, you can easily identify the outsiders…

Ah, ok.
My router shows me, if he has a “dynamic” address.
And I don´t have any, so no need for that trick anyway.

Yes. Plus having them managed from the router,
you can leave your Mac/iPhone/iPad (whatever)
set to DHCP and if you ever connect to another
network, you won’t be pulling your hair out for
an hour because you forgot that you have YOUR
network address set statically.

1 Like

Only if you are not careful. Suppose at a moment when your device with a manual IP address is down a separate new device connects to your network and requests an IP address from the router. Because the manual address is not being used at that time, the router could assign it to the new device. Then, when your manual device starts up, it encounters an error as the IP address is not available.

The solutions to avoid this have already been mentioned.

  1. Assign the manual IP address at the router, not the device. That way, the router will never assign that IP address to any other device.
  2. Use an address outside of the DHCP range. Again, this ensures that the router will never assign it to any other device.

Using both provides the best insurance. Using option 2 only could still result in a conflict if two devices have the same IP address manually set on the device. However, with option 1, the router will only allow you to assign an IP address to one MAC address (used to identify each device as unique) at a time. Therefore, there are no conflicts and all manual IP addresses are managed at one location.

Thats a very conscientious approaching, but that’s not really how IP address assignment works. Being down for a moment doesn’t put you at risk of conflicts.

In a home setting especially, there is no issue with assigning a static IP from the device.