Setting Watch face by time

Is anyone else running into an issue with personal automations to change their Apple Watch face at a set time?

I have three such automations: one that should run at 9:00 am, one that runs at 4:30 pm, and one that runs at 9:00 pm.

The automations for the afternoon and evening run perfectly, but the morning automation steadfastly refuses to run. Here’s what the 9:00 am and 4:30 pm automations look like:


As far as I can tell, they’re identical except for the specific watch face.

Does anyone have any ideas? This is admittedly a small matter, but it’s annoying.

Thanks for the idea. I’ll give it a try and report back.

First experiment/update: I tried changing the time of the offending automation to early afternoon and waited for it to do its thing. It worked just fine.

In the next episode, the automation will be reset to 9:00 am. If episode two goes badly, there’ll be a third episode in which the watch face is deleted and recreated…

I’ve set mine to change twice per day.
Will check if it changes tomorrow morning, have it set at 7 am.

One question though:
When it is supposed to switch, are you wearing it or is it still on the charger?

I’m wearing it. (20 characters)

1 Like

I had the same problem. I ended up deleting and rebuilding the automation. Since updating to 14.0.1.

1 Like

I just created my first automation, changing the watch face. Thanks for the inspiration! I’ll know in the morning if it works.

Same issue with updating to 14.0.1 - watch face and cinema settings stopped working until I recreated them. Lets see if they continue to work.

What’s odd is that I had three automations, all built the same way. Two of the three were working fine.

And the problematic one worked fine when I changed the time. We’ll see what happens now that I’ve changed the time back.

I have been having intermittent issues with this too. Worked fine to start with, then stopped working and then started again. No real reasons.

Don’t think it is the watch face itself, you can always test that the automation makes sense by hitting the play button on the actions screen to test it.

No idea why it isn’t working properly. Just realised that other times automations are also not running.

Really strange.
The automation works at 7pm, but doesn’t at 7am

Mine didn’t run at 9:00 am. So, out of curiosity, I reset the automation to run at 9:02. That worked fine.

Which makes me wonder if there’s an issue with having two set watch face automations with the same time, even if one’s pm and one’s am — and shortcuts then prioritizes the one that was created first.

I’ve made the same change, will know tomorrow if it worked :slight_smile:

Did not work for me. So, I’ll not spend time dealing with it. I’ll just slide the face. That always works. :slight_smile:

2 Likes

Still not working for me. None of the timed automations are. It used to work so this is irritating

1 Like

I change the time. It works. Fast forward 24 hours and nothing. Argh. This is so frustrating.

A good automation where you have to change the time everyday :see_no_evil:

seems to be working ok here - changed on time for the past 48 hours.
I did do a full reset to try and sort battery issues so had to re-create the watch faces again.

I had the same issue with changing watch faces by time but it started working again when I logged all my devices out of iCloud and back in. I was attempting to fix an extremely annoying unrelated issue but it seems to have done the trick.

On the other hand, triggering actions from workouts is as dead as ever…