SFTP connection problems in Germany with a Fritzbox

I’m currently visiting my parents in Germany. I have an SFTP connection set up in FileBrowser Pro.

The SFTP settings are correct and work in the UK. They work in Germany through my mobile phone data connection. The connection fails when connecting through my parent’s Fritzbox. I believe it may have something to do with port 22 being blocked, but am unsure.

Does anyone know what I need to do to get this working please?

As far as I know, SFTP is not (might not be) working thru a FritzBox in General.
You can have a look onto the HomeNetwork (Heimnetz) Tab, and there under USB/Storage (USB/Speicher). There is a box “Access via FTP active”, that should be disabled to get thru with a FTP connection, as the FritzBox can work as a kind of a NAS itself, and therefore is using the Ports 21 (and maybe also 22) for their internal connections.
If the box is disabled, you can go thru via Port 21 (with FTP), and maybe also with 22 (but I haven’t tried this by myself yet, as my SFTP-Port on my NAS has been set to an other value for security reasons.)
Also you can try to set the Firewall.
I haven’t found a englisch description yet, but maybe this one is of any help

I am a little confused. You are within the WLAN/LAN network of the Fritz!Box and you are trying to access a server on the internet using SFTP?! I am doing this all the time. The Fritz!Box does not block any outgoing traffic/ports.

Just in case: if you are trying to access the Fritz!Box as a NAS from the the Internet (so. the other way around), you have to use FTPS instead of SFTP:

So, there is some work to be done for incoming traffic, but not for outgoing traffic as far as I am aware.

1 Like

Thanks for your help, just cannot get this to work.

The FB 7490 does somehow block SFTP traffic. I’ve added SFTP to “Freigabe”, but no dice. I’ll have to do my SFTP via my mobile data.

I’m really disliking FB, what a terrible device. No such problem with routers in the UK.

I have now solved the problem.

In the FB settings under Internet > Filters devices are automatically restricted. Once I removed the restriction it worked.

1 Like

I am glad that you were able to solve the issue. “Freigabe” is the routing part for incoming connections (port forwarding). That is of no use regarding outgoing connections.

Filters are there to protect children or guest WiFi (limit their devices). The default is that those filters have no restrictions at all. They are basically turned off by default. Somebody must have turned on this protection by inadvertently changing the relevant profile perhaps.

More on Filters at:

I love those Fritz!Boxes - one device that has everything built-in - I have been using them for about 15 years (without the need to set a foot into “Filters”). Secure, frequent firmware updates, nice WiFi (Mesh capable, no cloud), no privacy issues, integrated solution for telephony, integrated DSL modem (or cable or fibre depending on the model), 1 GB LAN switch, integrated NAS (with limited functionality), USB printer sharing, easy to use VPN setup, marvelous diagnostics in case of an ISP outage and so on… :slight_smile: And … easy to use… by default (you can make it as complicated/sopisticated as you want, but you do not need to).