Share options show Brave (browser) instead of Mail

Greetings all,

Without making any conscious moves, I have ended up with a Brave browser option in my Safari browser Share options instead of the Mail option. See attached.

I would love some guidance about how to restore.
Screen Shot 2021-05-17 at 1.25.48 PM

open preferences → General → Default email reader → set it to (or any mail client of your preferences) Preferences for Default email reader

You likely accepted a permission pop up for a web app mail client (fastmail, gmail, anything) to be your default mail client. The share sheet will show default mail client to handle mailto: link. Most (if not all) browser acts as valid mail client too.

I had this problem a few months ago and that definitely solved the problem.

Yes and thank you ever so @ybbond! and to you too @grs