Siri: "I can't see an app for that"

Is anyone else having problems with Siri and non-Apple app? It seems to not be able to see apps which i have installed and it should work with.

For example, I have always used Siri to add tasks to Todoist. Has worked fine on iOS in the past but now Siri says that he can’t see the app.

Also, Siri is giving me issues on MacOS with Todoist. When I dictate a new action it tells me that I have to continue in Todoist. There is no ability to pass the command into Todoist. Not sure if these two issues are linked?

I don’t think that Siri has that capability on macOS. For your iOS problem, it looks like a hickup with registration of the todoist app. It might be useful to un- and re-install it to clear the caches or restart your iOS device.

1 Like

Works from lock screen on iPhone.

Never worked on Mac:

1 Like

Thanks. I am getting a different result from my lock screen. It keeps adding the reminder to Reminders and ignores the fact that Todoist is installed.

I realise now that it is not going to work on the Mac but annoying what it is failing on the phone.

Were you successfully using it before? If not you need to configure Siri to work with Todoist:

To get Siri to work with iOS 11 you must first set it up doing the following:

• Settings > Siri & Search
• Scroll down until you see Todoist and select it
• Select Use with Siri

Also see:

Yes, I was successfully using it with Siri in the past.

I have just unset the settings, reinstalled Todoist, re-set settings and it has just worked. Yay!


Sounds like a bit of a pain but I’m glad it’s working again.